Choose Language Hide Translation Bar
Highlighted
Eduardo
Level II

Virtual Join Tables by Script in JMP13

Hello All!

 

I've been trying to do this simple exercise: virtually join two tables created by another script (you could take the attached example tables). Below my code:

 

dtlink=data table("Report");
dtref=data table("MAIN");
dtlink:Pattern<< Set Property( "Link ID", 1 );
dtref:Pattern<< Set Property( "Link Reference", Reference Table( "Report.jmp" ) );

 

This is the issue...When I run the script the Report gets the "golden key" but the "MAIN" table get a "grey" key (not a blue one, and blue means it works) IF the tables are not saved. When I do all manually it works. Now when both tables are saved somewhere and I run my script, it works. I would like not to save the tables for my purpose. Am I doing something wrong? 

 

If you take the tables I attached then the script will work. Copy the data to new tables (with new names) without saving them, run my script with the new table names, and it will not work. I do not understand! 

 

Any help appreciated!

 

Eduardo 

 

 

 

1 REPLY 1
Highlighted
gzmorgan0
Super User

Re: Virtual Join Tables by Script in JMP13

I documented this behavior to JMP near the end of August 2017. 

The tracking number was  [SAS 7612212360]  for JMP 13.2.  JMP Support responded with

 

>> 

Although the documentation does not explicitly state this is required, it is implied on the following page of the Using JMP pdf. (see highlighted screenshot of page 256 of Using JMP from their response) ...after speaking with a few resources here, the tables should be saved to disk before performing Virtual Joins.

<<

It seems the current version needs the Link Reference to have a .jmp extension which implies it is saved to disk.  Currently, it has the same behavior in JMP 14.

Article Labels

    There are no labels assigned to this post.