Choose Language Hide Translation Bar
Level I

JMP Script closes after running, interaction with C#?


I recognize that this might be vague and I apologize as I am not fully at liberty to show all of the data that I am manipulating, but I will try my best to provide as much information as possible.


I have been provided a JMP Add-in to perform a 4PL regression. This Add-in is a combination of JMP files and an executable. I do not have access rights to the executable (cannot edit this file). The JMP files for the Add-in provide data cleaning for the executable and then call the executable. The executable interacts with the file that is open, it would simply update the file with the 4PL data and that's it.


My task was to automate the process of running the add in, we have several input files that we would run daily. The approach I was planning on taking, was taking the file that runs the executable and treating it / wrapping it as a function, I would then iterate through my list of data tables. 


I did this in a piecewise fashion:

  • I first made sure the executable was working on the input data.
  • I then wrote the function and a separate script window("wrapper") to select the data table and pass it to the function. I did this for a single file and it worked correctly.

Below is my "wrapper" for calling the function, the code below works correctly:


include("$ADDIN_HOME(**path I cannot share**)\DRIA_func.jsl");

test1 = data table("First Data Table for Script");

var_1 = DRIA_func(test1);

However, once this is run, the script window above closes, I do not have control of this and I cannot stop it. If I were to add a second data table, the following error is observed in the log:

In the following script, error marked by /*###*/
Include( "$ADDIN_HOME(**path I cannot share**)\DRIA_func.jsl" );
test1 = Data Table( "First Data Table for Script" );
var_1 = DRIA_func( the_table_test1 );
test2 = Data Table( "Second Data Table for Script" );
var_2 = DRIA_func( the_table_test2 ) /*###*/;

I don't know why the script window is closing, but I imagine that this is causing the error. 


The JMP script that I am turning into a function, if I run it on it's own, it provides the correct result to the data table but then force closes as well.


The only reference I have is this community link:


From what I gather this is part of the C# coding and is not something I can mitigate in / through JMP. I'm the only resource on this, and before I conclude it's a problem with the executable, I wanted to ask the experts here!


Thanks for your help!






Article Labels

    There are no labels assigned to this post.