BookmarkSubscribe
Choose Language Hide Translation Bar
psangior
New Contributor

column scroll lock keeps "inching" back

Hi -

 

I'm using JMP14.0.0 and recently I've run into a bug that is so frustrating that I decided to register for these (always very valuable) forums to report it.

 

Issue

  • Start with a nice, wide dataset
  • Select scroll lock on a few columns
  • Scroll the unlocked columns over to the right a bit
  • Now, click on any of the "locked" cells and start typing
  • Watch as the "unlocked" columns start "inching" back to the left.
  • Each cell that you type in, the scroll on the "unlocked" colums inches over

This is extremely frustrating if you are (like me) trying to modify something from the left-hand side of your database based on data from the right-hand side and don't want to rearrange the columns.  Ultimately, it really defeats the whole point of column scroll lock, honestly.

 

Happy to try and clarify this if my description isn't adequate.  Thanks!

0 Kudos
2 REPLIES 2
gzmorgan0
Super User

Re: column scroll lock keeps "inching" back

This note does not address the behavior you are seeing, but describes and alternate option.

  1. Highlight the columns that are needed for editing, make sure no rows are selected.
  2. From the menu select Tables > Subset, and choose the options All rows, Selected columns and Link to original table.
  3. All edit you make in teh subset table are made in the main table. 
  4. Close the subset table, no need to save, but do save the original table.

 

Hope this helps.

psangior
New Contributor

Re: column scroll lock keeps "inching" back

Thanks for the great suggestion.  This is a really helpful work-around!

0 Kudos