Subscribe Bookmark RSS Feed

Lack of continuity opening CSV Files

matt7109

Contributor

Joined:

Jun 9, 2017

Hi,

It seems like most of the time, when  I open a CSV file as a JMP table, the first row of the CSV file become column names. However, on some occasions, when I open the same CSV files, the first row of the CSV file will become the first row of the JMP table with no column names. 

Why is this and how can I ensure continuity when opening CSV files?

1 ACCEPTED SOLUTION

Accepted Solutions
Craige_Hales

Staff

Joined:

Mar 21, 2013

Solution

The preferences control how JMP interprets the CSV. The default assumes there are column names on line one of the CSV.

Text Import PreferencesText Import Preferences

If you tell JMP to guess (radio buttons at top), then you might get the behavior you describe because JMP guesses there are no column names if there are numeric values on the first row.

If you are importing the same file structure (same columns, same names) again and again, you might want to use the "source" script stored in the table to repeat the process. It will not depend on preferences.

Craige
2 REPLIES
David_Burnham

Super User

Joined:

Jul 13, 2011

You might want to take a look at text data file preferences to see whether you can set some sensible defaults:

 

https://www.jmp.com/support/help/13-1/Text_Data_Files.shtml

 

 

 

-Dave
Craige_Hales

Staff

Joined:

Mar 21, 2013

Solution

The preferences control how JMP interprets the CSV. The default assumes there are column names on line one of the CSV.

Text Import PreferencesText Import Preferences

If you tell JMP to guess (radio buttons at top), then you might get the behavior you describe because JMP guesses there are no column names if there are numeric values on the first row.

If you are importing the same file structure (same columns, same names) again and again, you might want to use the "source" script stored in the table to repeat the process. It will not depend on preferences.

Craige