Choose Language Hide Translation Bar
Highlighted
Françoise
Level IV

Problem with Excel

hi,

 

someone has made for me  a database with Excel.xlsb.

 

When I import it, the database opens with Excel.

 

is there a solution to import it with Jmp?

 

best regards

11 REPLIES 11
Highlighted
David_Burnham
Super User

Re: Problem with Excel

I did a quick search and found these: save data table as excel xlsb and How to open .xlsb file? 

-Dave
Highlighted
Françoise
Level IV

Re: Problem with Excel

thanks David for your answer.

 

I 've seen the message of Tom Abramov (2019).

 

I hoped that someone of the R&D had found a solution because *.xlsb is interesting to reduce the size of the excel files.

 

best regards

Highlighted

Re: Problem with Excel

Does the File > Database > Open Table approach work with workbooks saved using the binary XLSB format?

Learn it once, use it forever!
Highlighted
David_Burnham
Super User

Re: Problem with Excel

Could be a good route - The ODBC driver for Excel files supports XLSB formats.

David_Burnham_0-1592412500266.png

 

-Dave
Highlighted
Françoise
Level IV

Re: Problem with Excel

I haven't  connection in the database Operations

My Jmp is 64 but my Excel is 32 and I'm not used to use ODBC.

 

I tried with the query builder but it could not be executed.

 

May be someone else can test it to help others members?

Highlighted
stan_koprowski
Community Manager Community Manager

Re: Problem with Excel

Hi @Françoise 

If you match the bitness of your ODBC driver to that of JMP it should work.

I was able to import the VA Lung Cancer data provided in the sample data using JMP Query Builder.

 

Import .xlsb file using JMP Query BuilderImport .xlsb file using JMP Query Builder

 

cheers,

Stan

Highlighted
Françoise
Level IV

Re: Problem with Excel

dear Stan,

 

I will try it

 

Highlighted
Françoise
Level IV

Re: Problem with Excel

Stan,

 

no success with your solution.

 

can you give me the beginning of this script?

 

best regards

Highlighted
mzwald
Staff

Re: Problem with Excel

If you are opening Excel files with JMP, make sure the "Use Default Program to Open" box is unchecked when selecting from the File Open dialog window. That way the file opens in JMP rather than the default program (Excel).
Article Labels