Subscribe Bookmark RSS Feed

Excel Add-In Data Table Name in Excel 13

kennedy3

Community Trekker

Joined:

Jul 2, 2015

I've used the JMP Excel add-in for quite some time, but I've started having problem with the data table name in JMP 13.  Before I upgraded, when I used the add-in to create a JMP data table from an Excel spreadsheet, the JMP table would be named  with a combination of the Excel file name and sheet name.  Now the JMP table is named "Untitled".  I checked my preferences in the add-in, but the field is empty.  After reveiwing the Using JMP chapter dealing with the add-in, I went back to preferences and changed "Data Table Name" from blank to "File Name_Worksheet" and now my data tables are all named "File Name_Worksheet".  How can I get the add-in to create a data table with the actual file name and worksheet?  Can I further customize this so that it defaults to just the worksheet name?

Thanks!

4 REPLIES
briancorcoran

Joined:

Jun 23, 2011

Hi,

 

This may be a defect. I  encourage you to contact JMP Technical Support and see if they can replicate your problem.  If they can, they will open up an issue so that this gets fixed in a future release.

 

Brian Corcoran

JMP Development

briancorcoran

Joined:

Jun 23, 2011

Hi,

 

I've investigated this further and regrettably this is a bug that was introduced into the addin for JMP 13.  I will enter a defect and see if this can be fixed for the 13.2 release.

 

There is a workaround for this issue.  If, in the JMP Add-in ribbon bar within Excel, you go to Preferences and change a preference and hit ok, a preference file will be saved out.  From that point on, the issue will go away.  You may have to change a preference and then change it back if you like the default settings.  It is the absence of the preference file that is causing this issue.

 

Brian Corcoran

JMP Development

kennedy3

Community Trekker

Joined:

Jul 2, 2015

I've tried the workaround a couple of times and it's still not working.  I may just have to wait for 13.2!

L3ph7Y

Community Member

Joined:

Jan 27, 2017

Have you tried using the following in the excel preferences box:

 

&[File]_&[Tab]

 

I had the same issue and that seems to be working for me.