Choose Language Hide Translation Bar
Highlighted

Can't change legend in Legend Settings

Using JMP8.0.2 (Windows 7--64-bit) and I'm new to JMP.

I created a bar chart (using Chart) and I want to change the legend. I can change the title but when I change one of the legend entries it shows up in the preview but when I click OK the change is not reflected in the chart. Any suggestions?

Thanks,
Adrian.
0 Kudos
5 REPLIES 5
mpb
Super User mpb
Super User

Re: Can't change legend in Legend Settings

1. This looks to me like a reportable bug. To submit this to JMP support you can use the link at the bottom of this page "software issues that require SAS action" .

2. You may have better luck getting the Legend to look as you prefer if you play a bit with the graph builder: Graphs>Graph Builder.
0 Kudos

Re: Can't change legend in Legend Settings

It works in Graph Builder but I have yet to figure out how to get error bars in Graph Builder, hence why I was using Chart.
0 Kudos
mpb
Super User mpb
Super User

Re: Can't change legend in Legend Settings

What about the brute force method of changing the column name?
0 Kudos

Re: Can't change legend in Legend Settings

It just adds "Mean([columnName])" as the legend entry title. No way to get around that. SAS has assigned it a bug number so I'm guessing it's a real bug.
0 Kudos
lparlett
Community Member

Re: Can't change legend in Legend Settings

I am still having this problem in version 9.0, despite the Problem Note (http://www.jmp.com/support/notes/38/366.html) saying that it has been fixed in the new JMP.
0 Kudos