Subscribe Bookmark RSS Feed

Remove jitter when creating custom error bars in Graph Builder

bobzsun

New Contributor

Joined:

Aug 14, 2017

I'm creating custom error bars using existing summary data using the method described here.

 

When I am just using one group of data, and adding a line to connect data points, things work as expected:

no jitter.png

 

 

However, when I overlay multiple groups of data, the "bars" (the error bars) automatically jitter for every x-value so that they don't sit on top of each other:

 

jitter.png

 

You can see that because of the jitter, the line no longer goes through the point in the error bar. More importantly, because this is longitudinal data, the jitter gives the impression that the x-values for the overlaid data are different, when in fact they are the same.

 

I'v already tried removing the midpoint of the error bar and instead plotting it separately as a "point," but that doesn't work, because while it causes the line to go through the point, it still has jittered error bars.

 

Is there a way of removing the jitter for these summary data?

1 ACCEPTED SOLUTION

Accepted Solutions
bobzsun

New Contributor

Joined:

Aug 14, 2017

Solution

I contacted JMP support directly, who were very responsive but ultimately gave me bad news:

 

"Unfortunately, I don't believe there is a way to create the same custom error bars plot with summary data using an overlay variable."

 

So it seems like this is only possible if you have the raw data.

1 REPLY
bobzsun

New Contributor

Joined:

Aug 14, 2017

Solution

I contacted JMP support directly, who were very responsive but ultimately gave me bad news:

 

"Unfortunately, I don't believe there is a way to create the same custom error bars plot with summary data using an overlay variable."

 

So it seems like this is only possible if you have the raw data.