Share your ideas for the JMP Scripting Unsession at Discovery Summit by September 17th. We hope to see you there!
Choose Language Hide Translation Bar
Highlighted
Harj
Level II

No longer able to find the Shapiro Wilk test

Hi,

I am suddenly unable to find the Shapiro wilk test when assessing data for normality. I used to use the distribution --> continuous fit --> normal --> then goodness of fit (which was shapiro wilk by default if i remember correctly)

Now i dont get 'normal' as an option, instead i get' fit normal' and then the goodness of fit test is Anderson- Darling.

 

Any idea what happened?

 

Thanks.

 

pic 2.pngpic 1.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
louv
Staff (Retired)

Re: No longer able to find the Shapiro Wilk test

This answer was provided @txnelson....

The Shapiro-Wilk test has deemphasized and moved to being a legacy statistic.  To gain access to it, run the Distribution Platform.  Under the red triangle for the Column being analyzed select

     Continuous Fit==>Enable Legacy Fitters

Then go back to the red triangle, and the new selection option will appear

     Legacy Fitters==>Continuous Fit

The Shapiro-Wilk test will be displayed when you select the Goodness of Fit under the Legacy Fitters

View solution in original post

6 REPLIES 6
Highlighted
louv
Staff (Retired)

Re: No longer able to find the Shapiro Wilk test

This answer was provided @txnelson....

The Shapiro-Wilk test has deemphasized and moved to being a legacy statistic.  To gain access to it, run the Distribution Platform.  Under the red triangle for the Column being analyzed select

     Continuous Fit==>Enable Legacy Fitters

Then go back to the red triangle, and the new selection option will appear

     Legacy Fitters==>Continuous Fit

The Shapiro-Wilk test will be displayed when you select the Goodness of Fit under the Legacy Fitters

View solution in original post

Highlighted
AV
AV
Level II

Re: No longer able to find the Shapiro Wilk test

Hi,

 

Even after enabling the legacy filters and going to

Legacy filters ====> Continuous fit

The Shapiro-Wilk option does not show up and if if you run Normal, the KSL test result is displayed. No other Goodness of Fit option under legacy filters. See attached image. (JMP 15.1.0 Pro)

Highlighted
louv
Staff (Retired)

Re: No longer able to find the Shapiro Wilk test

Screen Shot 2020-04-25 at 12.18.29 PM.png

 

Distribution>Continuous Fit>Enable Legacy Fitters>Legacy Fitters>Continuous Fit>Normal>Goodness of Fit

 

This is from JMP 15.1

Highlighted
AV
AV
Level II

Re: No longer able to find the Shapiro Wilk test

Thank you very much for your quick reply and screenshots. I had done those steps and it still wouldn't work. I even reset the platform preferences to defaults just in case there was some bug. I was going crazy until I realized my sample was >2000, in which it would default either to the Anderson-Darling test only (through the new fitter, even when legacy fitter had been enabled) or the KSL test (if done via the legacy fitter). If I decrease my sample to below 2000, it works. Thanks again.
Highlighted

Re: No longer able to find the Shapiro Wilk test

@louv is correct, but it is unnecessary to use the legacy fitter for a normal distribution model. The Shapiro-Wilk test was added to the new fitter along with the Anderson-Darling test in the JMP 15.1 maintenance release.

 

Screen Shot 2020-04-25 at 1.29.50 PM.png

 

 

Learn it once, use it forever!
Highlighted
AV
AV
Level II

Re: No longer able to find the Shapiro Wilk test

Thank you very much for your quick reply and screenshots. I had done those steps and it still wouldn't work. I even reset the platform preferences to defaults just in case there was some bug. I was going crazy until I realized my sample was >2000, in which it would default either to the Anderson-Darling test only (through the new fitter, even when legacy fitter had been enabled) or the KSL test (if done via the legacy fitter). If I decrease my sample to below 2000, it works. Thanks again.

Article Labels

    There are no labels assigned to this post.