Subscribe Bookmark RSS Feed

My script editor is very slow

ursula_garczare

Community Trekker

Joined:

May 1, 2012

it is lagging behind my typing and I am not a fast typer! Does anyone have/had the problem? Is there a solution? I am working on Windows 7  (64), and my resource monitor shows some 25% CPU usage when I scroll in my scripts, which also sounds too much to me...

Ursula

1 ACCEPTED SOLUTION

Accepted Solutions
ursula_garczare

Community Trekker

Joined:

May 1, 2012

Solution

Dear Jeff,

the extreme slow performance is solved: has nothing to do with JMP, only it impacted JMP much more than any of the microsoft products. It's been a miscommunication between the labtop and the docking station, solved by using another docking station, technical details were above my understanding.

Sorry for bothering, and thanks for providing help!

Kind regards,

Ursula

4 REPLIES
Jeff_Perkinson

Community Manager

Joined:

Jun 23, 2011

Do you have the "Color unknown object messages" option turned on?

7136_Pasted_Image_8_20_14__5_53_PM.png

That option can affect script editor performance. If it's on, try turning it off and see what happens.

If that's not it, can you give us some more details on the problem?

Does the typing problem happen with an empty script editor?

How many lines is the script that is scrolling poorly? Do you have lots of JMP windows open or just the script editor?

-Jeff

-Jeff
Jeff_Perkinson

Community Manager

Joined:

Jun 23, 2011

One more thing, what version of JMP are you using?

-Jeff

-Jeff
ursula_garczare

Community Trekker

Joined:

May 1, 2012

Dear Jeff,

sorry I was not answering. Got a brand new computer, hoped my problem would disappear but it persists. The color option is off, and obviously not the root cause of the problem. When typing in an empty script the lag is just as bad as with some 200 lines script.

I am working with JMP Pro 11.2.0 64 bit under MS Windows 7 Enterprise 64 bit, SP1.

Help is very welcome .

Regards,

Ursula

ursula_garczare

Community Trekker

Joined:

May 1, 2012

Solution

Dear Jeff,

the extreme slow performance is solved: has nothing to do with JMP, only it impacted JMP much more than any of the microsoft products. It's been a miscommunication between the labtop and the docking station, solved by using another docking station, technical details were above my understanding.

Sorry for bothering, and thanks for providing help!

Kind regards,

Ursula