BookmarkSubscribe
Choose Language Hide Translation Bar
Highlighted
crofut
Community Trekker

Linear Contrast in Fit Model

I've noticed that when using Fit Model (even for a simple one-way ANOVA), that the Linear Contrast is not correctly saved when I save the script to the data file to re-execute at a later time.  Also, since I'm creating (attempting) several contrasts, is there an easy way to label/title each constrast?

0 Kudos
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Linear Contrast in Fit Model

Hi Steve!

 

This is a bug in version 13 of JMP. Updating to 13.2 will fix the problem.

 

From the 13.2 release notes on fixes made:

Standard Least Squares • When you create an LSMeans Contrast and then save the script for the analysis, the LSMeans Contrast is saved correctly in the script. • The Contrast Specification boxes are aligned correctly

 

As for the labeling of the contrasts, I don't know of any way to easily do that. 

Dan Obermiller
0 Kudos
5 REPLIES 5

Re: Linear Contrast in Fit Model

I'm not seeing a problem. Which version of JMP are you using? Can you show the script that is saved along with the output that the script SHOULD be producing?

Dan Obermiller
0 Kudos
crofut
Community Trekker

Re: Linear Contrast in Fit Model

Hi Dan,  I'm using JMP PRO 13.0 (64-bit).  I can't email JMP files (security blockage at company).  SO I've attached a PPT file that shows a simple data table, with the script.  It also shows the original output, and the output when the script is re-executed.

 

Thanks,

Steve

0 Kudos

Re: Linear Contrast in Fit Model

Hi Steve!

 

This is a bug in version 13 of JMP. Updating to 13.2 will fix the problem.

 

From the 13.2 release notes on fixes made:

Standard Least Squares • When you create an LSMeans Contrast and then save the script for the analysis, the LSMeans Contrast is saved correctly in the script. • The Contrast Specification boxes are aligned correctly

 

As for the labeling of the contrasts, I don't know of any way to easily do that. 

Dan Obermiller
0 Kudos
ghartel
Community Trekker

Re: Linear Contrast in Fit Model

I'm on version 14.1 and it seems there is a similar problem. I'm using Generalized Linear Model to fit a logistic and I'm using contrast to compare levels of a categorical variable. It works fine point and click but the script only saves "Run(Contrast( 1 ))" which requires the contrasts to be specified manually again. I don't see anything in the documentation about how to specify the contrasts via script. Is this just not implemented?
0 Kudos
julian
Staff

Re: Linear Contrast in Fit Model

Hi @crofut,

 

It looks like Dan addressed your main issue, but with regard to labeling, when I need to keep track of several contrasts I find it's helpful to simply rename the outline boxes (i.e. double click on the outline box title). This renaming is preserved in the script you save for the report.

 

I hope this helps!

 

Julian

 

Contrast Label.gif