Choose Language Hide Translation Bar
Highlighted
Jun1
Occasional Contributor

Latent Class Analysis: there was a problem fitting the specified model.

Hi all,

I want to perform the Latent Class Analysis. When I do this, I can get the results, but there is a message; 'there is a problem fitting the specified model. It is likely that the specified model is not identifiable. Try fitting a model with 0 or fewer clusters'. In this case, Can I consider the presented results valid?

If not, what should I do? I enter the number 0 in 'Nemuber of Clusters', when I do the LCA. then I am asked to enter the number of cluster. I am a beginner in latent class analysis.

I would be happy if you could suggest any advice.

 

Thank you in advance.

 

Best,

Jun

 

0 Kudos
8 REPLIES 8
phil_kay
Staff

Re: Latent Class Analysis: there was a problem fitting the specified model.

Hi Jun,

Can you share a bit more about the data that you have? How many variables are you clustering on? How many categories does each variable have? How many rows do you have?

If you are able to share anything else about your situation and objectives it should help the community to understand your problem and provide solutions.

Regards,
Phil
0 Kudos
Jun1
Occasional Contributor

Re: Latent Class Analysis: there was a problem fitting the specified model.

Hi Phil

Thank you for your reply.
I have data on the survey results.
My data is 134 rows (134 participants) and 128 column (128 questions). I want to cluster
participants based on the results of questions.
Each question have two items (1: yes 0:no). There are many question items for which
everyone has the same answer. I suspect that this may affect the results of the latent
class analysis.
I'm happy if you could give me some advices.

Thank you in advance.

Best
Jun
0 Kudos
phil_kay
Staff

Re: Latent Class Analysis: there was a problem fitting the specified model.

It would be a good idea to find how many questions you have where everyone gave the same answer. These columns will be no use in the latent class analysis.

First of all check that the question answer columns are all defined as nominal modelling type.

Then I would use Columns Viewer from the Cols menu and Select all of your 128 Question columns and Show Summary. From the Summary Statistics red triangle menu you can select Data Table View. Then in the data table, right-click on any cell where N Categories = 1 (a column with only one answer for all participants) and right-click > Select Matching Cells. Now all of the columns with only one answer will be selected in your original table. In the columns panel of the original data table you can right-click on one of the selected columns > Group. Now you have the columns with only one answer grouped together so you can ignore them in your latent class analysis.

How many columns are you left with? Explore some (or all) of them with Distribution. Do you get any indication of clusters?
0 Kudos
Jun1
Occasional Contributor

Re: Latent Class Analysis: there was a problem fitting the specified model.

I checked the column with only one answer for all participants, then I excluded three
column from the LCA. But the results shows error message, again. Then I reviewed column.
There are some column that have biased answers which showed <5% frequency ratio. I
excluded these columnand compute the LCA. But the situation does not change.

What other reasons can the model not converge?
0 Kudos
phil_kay
Staff

Re: Latent Class Analysis: there was a problem fitting the specified model.

Are you able to share the data? Perhaps you could anonymise the data first.

0 Kudos
Jun1
Occasional Contributor

Re: Latent Class Analysis: there was a problem fitting the specified model.

I'm sorry to be late reply.
Sure, I'd love to. I've finished the anonymise the data.
Could you show me how to share the data?

0 Kudos
phil_kay
Staff

Re: Latent Class Analysis: there was a problem fitting the specified model.

There is an option to drag and drop or browse files to attach below the "Body" section when you reply in a discussion thread. 

0 Kudos
Jun1
Occasional Contributor

Re: Latent Class Analysis: there was a problem fitting the specified model.

Here is the data.

row is subject ID, and column is activity items (make anonymous).

subject = 134, activity item = 128

value 1 = subject answered 'do', 0 = 'not do'.

no.123 - 134 : no data in gender and age

 

Thank you in advance.

0 Kudos