Subscribe Bookmark RSS Feed

JSL Debugger Won't Launch

mewing

Community Trekker

Joined:

Jun 23, 2011

Whenever I try and launch the JSL Debugger (from JMP 10 - not Pro) I get a note saying:

Time out encountered attempting to connect to the JSL Debugger GUI

Do I need to connect to an external server to launch the JSL Debugger?

8 REPLIES
kevin_hankins

Community Trekker

Joined:

Feb 5, 2015

I have the same problem on my first try to use the Debugger.

mikedriscoll

Community Trekker

Joined:

Jun 23, 2011

I had this problem on JMP 11.2.0 on my last PC (Win XP and also Win8 after I switched over), and now again on JMP11.2.0 on my current PC (Win8). I might have had the same problem in JMP 10.x as well; I don't recall.  All were non-pro JMP editions. I mentioned it to some of the JMP folks at the JMP summit in September. They told me to contact tech support.  I've been too busy; haven't contacted them.  I'll be watching this thread though.

-Mike

XanGregg

Staff

Joined:

Jun 23, 2011

The JSL debugger starts another process that communicates with JMP via sockets. Some OS configurations may disallow that as a security issue. Tech support should know the common cases and possible workarounds.

stan_koprowski

Community Manager

Joined:

Aug 8, 2012

Hi,

See similar thread  JSL Debugger will not launch 11.2.0 and options to investigate. Craige@JMP mentioned some security options that could be enabled that are preventing JMP from communicating.

Stan

mikedriscoll

Community Trekker

Joined:

Jun 23, 2011

I opened up a ticket with JMP tech support and as part of that discussion, my firewall settings were questioned (my company's settings, I should say). I mentioned the problem to our IT group. We temporarily disabled the McAfee firewall and the debugger was able to load just fine. Further testing was done to figure out a permanent workaround on our end. Specifically we opened up the firewall console, put it in learn mode, then adaptive mode, and tried running the debugger in both cases. Then I took the log file which showed what was being blocked, and forwarded it to IT so they can (hopefully) implement a workaround. I'll post back when I have an update.

galactus3000

Contributor

Joined:

Nov 9, 2016

Having significant issues with this and hoping next revision of JMP fixes it (was hoping it'd be fixed in JMP 13.1.0.

My company's IT department has bigger fish to fry than poking holes in the firewall for a piece of software that only a fraction of employees use.

Please fix in next revision.  Shouldn't have to tweak firewalls to use the Debugger.

 

Wendy_Murphrey

Joined:

Jun 23, 2011

Thanks to testing assistance from several JMP users ( mjdeez, kevin.hankins and others), we were able to confirm that various VPN and firewall settings may block launching of the JSL Debugger. In these instances, you will see the following error message:

                Time out encountered attempting to connect to the JSL Debugger GUI.


To resolve this issue, you will need to contact your local IT staff to review and adjust your VPN and firewall settings to allow application access for JMP.exe to the host.  Specifying a set of ports in the settings is not sufficient, as a new set of ports is selected each time the JSL Debugger is launched.   Keep in mind that these settings may need to be updated in the future when a new version of JMP is installed.

I hope this information is helpful.

Wendy

See also JMP Usage Note 55411.

Wendy
mikedriscoll

Community Trekker

Joined:

Jun 23, 2011

Huge thanks to Wendy, Bobby, and the developer at JMP who helped troubleshoot this for me. I confirmed it on a test case that Wendy's solution works, and my company's IT staff is implementing this firewall update.

-Mike