Share your ideas for the JMP Scripting Unsession at Discovery Summit by September 17th. We hope to see you there!
Choose Language Hide Translation Bar
Highlighted
hagaishalev
Level I

JMP14 Unable to fetch results set

Trying to get data from SQL server with stored procedure failed in JMP14 and succeed in JMP8 and JMP9.

in JMP14 there is an error:

JMP Alert: Unable to fetch results set.

JMP AlertJMP Alert

and there is no result table (show(t1); return "t1=.)

I get the same issue in JSL and with "Databse Open Table"

The stored procedure output countains few empty sets, which need to be skkiped. Apperntly the JMP8 is doing it automatcly, but not the JMP14.

SQL outputSQL output

Using Python I overcome this issue by cursor.nextset() untill I get a set with values.

I tried variety of formats, including:

 

dbc = Create Database Connection(
 
       "DSN=*******;UID=*****;PWD=*********;APP=JMP;WSID=SYS-CB2;DATABASE=Iserve;LANGUAGE=us_english;"
 
);
 
 
t1 = Execute SQL( dbc, "exec PL_RawData_restart '50110326','08/01/2018','08/16/2018' " );

 

 

 

RawData_dt=Open Database("DSN=*******;UID=****;PWD=*****;APP=JMP;WSID=SYS-CB2;DATABASE=Iserve;LANGUAGE=us_english", "exec PL_RawData_restart '48300134', '2018-07-17', '2018-07-31'");

 

2 REPLIES 2
Highlighted
gzmorgan0
Super User

Re: JMP14 Unable to fetch results set

I have not used a stored procedure, but here is a link to a JMP blog March 2017 for JMP 13

 

https://community.jmp.com/t5/Discussions/Database-stored-procedure/td-p/36885

 

another regarding NO COUNT ON for JMP 11

https://community.jmp.com/t5/Discussions/JMP11-MSSQL-Stored-Procedure-Call/td-p/10906

 

a note on why a stored procedure worked in JMP 8 and not in JMP 11

https://community.jmp.com/t5/Discussions/Importing-SQL-using-a-temp-table/td-p/11760

 

Hope these give you some leads.

 

 

Highlighted
hagaishalev
Level I

Re: JMP14 Unable to fetch results set

Thank you! There might be no solution for my issue from the JMP side.
Article Labels

    There are no labels assigned to this post.