Subscribe Bookmark RSS Feed

Help to improve display resolution of a surface profiler graph in JMP itself

sibylle_herzer

Community Trekker

Joined:

Oct 1, 2014

My main issue is that the display is very low resolution from the get to go. I've tried to look through settings and I can only see preferences for exporting at 300 dpi or higher but I don't see any settings to change my own display of the graph in jmp too a higher resolution. Consequently even if I export as an eps or vector file, I don't have a good quality picture because it looks so poor from the get go. E.g. the grid lines and box lines are all wavy (regardless of how small or big I drag the gaph in jmp). I've tried overcoming it by saving the prediction expression and then using the graph drop down to build the surface map, but the only resolution increase option I can find there is for the surface itself. The numbers for my contour lines are all messed up. I tried calling JMP tech support but don't have high hopes as I was told that this is likely due to the fact that I am only working with JMP 10. Not sure how true that is, but any insights would be appreciated. I went through the tutorial from D. Valente as well as the one page guides, but they all just speak to how to make sure that the export itself does not deteriorate resolution,not really how to increase the resolution in JMP itself so that you start from the correct resolution.


Also, is there any script that will change my color settings from RGB to CMYK when I export a TFF file?

Thank you so much, any help would be greatly appreciated...

I've attached a screenshot of what I see in JMP

10 REPLIES
julian

Staff

Joined:

Jun 25, 2014

Hi sibylle.herzer,

There isn't a way to change the display resolution in JMP, but I think I have a way to get you a larger exported graphic so you don't have the issues with your lines being fuzzy. To do this, you need to enlarge the surface plot in JMP (hover your mouse over the bottom right corner until you get the double-arrow, then drag to enlarge the plot). By enlarging the plot in JMP you will be exporting a larger image (in terms of total pixels, since there is literally more to copy). So, at the same display size, you'll get a sharper image.


For example, in the image below, the left pane was a copy from JMP with the default surface plot size; the image on the right is a copy from JMP after I had made the surface plot as large as my screen. Side-by-side you can see that the second copy is sharper (there are simply more pixels to work with because there were more to start with).

7925_Screen Shot 2015-01-18 at 9.26.34 AM.png

This process works all across JMP -- a larger display size in JMP provides more pixels for the copy/export to work with.

I hope this helps!

julian

sibylle_herzer

Community Trekker

Joined:

Oct 1, 2014

Julian, thank you for the tip. I usually do increase the size of the image in the manner that you describe, but do not seem to get any of the benefits you described. Is there any chance that this is not working for me because of my version of JMP (it not being Pro)? Thank you.

julian

Staff

Joined:

Jun 25, 2014

Hmm, I can't think of any reason why it wouldn't work in standard JMP, or JMP 10 as you said you were using. Would it be possible for you to share a script and some of the data you're using to make that graphic? I would be happy to try it out on my side; perhaps there is something unique happening here.

julian

sibylle_herzer

Community Trekker

Joined:

Oct 1, 2014

Hi Julian,

Thank you and that would be great. The data is attached. Hope you can see that the resolution for the sheet is nice, but the text for contour lines looks terrible and the grid & axis lines are all wavy… This is after I made the graph full screen size. It does not change.

Cheers,

Billie

julian

Staff

Joined:

Jun 25, 2014

Hi Billie,

I've attached the graphic I get when making the surface plot my full screen (1920x1200 for this output), then copying the output to my clipboard and opening/saving it from Preview (on my mac) to a PNG at 300dpi. How does this compare to the graphic you get?

Julian

sibylle_herzer

Community Trekker

Joined:

Oct 1, 2014

Wow, that looks a lot better than anything I can do on my PC. Even if I make the graph full screen size it just emphasizes the wobbliness of the lines. It’s like night and day. I wonder whether this is then somehow related to my OS settings for display or screen resolution (though my settings are at the OS recommended 1680x1050). That’s actually the max resolution I can set it too for my screen. So I don’t know how to fix that?

Thank you for sharing. I really have to think this over. Unfortunately, I get JMP through work and cannot run it on my Mac at home. Otherwise this would have been a real easy solution.

Cheers,

Billie

mpb

Super User

Joined:

Jun 23, 2011

This seems to help for me:

1. Create your plot

2. Right Click in the plot

3. Click on the "Use Hardware Acceleration" item

Michael

Hmmm...This makes a difference for me in JMP but copy/pasting into Powerpoint does not seem to improve though.

sibylle_herzer

Community Trekker

Joined:

Oct 1, 2014

Tried that already a while back, unfortunately, that did not help.

Cheers,

Billie

Craige_Hales

Staff

Joined:

Mar 21, 2013

Try this: journal the surface plot.  (Edit->journal).

(Optional) Right-click->settings, make the line weight and font bigger.

7952_surface1.PNG

Now stretch the surface plot bigger, maybe twice the size of the screen, so you have to scroll the journal to see it all.  You'll have to move the sliders and grab the bottom right corner several times.  The journal makes it possible to resize the plot bigger than the screen.

7953_surface2.PNG

Now save that as a PNG file.  You can see this image is being squished to make it fit.

7954_surfacePlot.png

actual size looks like this (if your browser is scaled to 100%)

7955_surface3.PNG

Now you can load the PNG file and resize (smaller) it to fit your needs.

Update:  in JMP10 you probably need to use edit->layout rather than edit->journal; the JMP10 journal isn't letting me size the graph bigger.

Craige