BookmarkSubscribeRSS Feed
Choose Language Hide Translation Bar
guleiss

Community Trekker

Joined:

Feb 23, 2016

Re: Contour plot weird problem

Hi Lou,

Thanks for looking into it. I am glad to get the contour plot :-). I did contour plot with other software. But I just wanted to make all my contour plot in my slides consistent. I will submit a technical support and keep everyone updated.

Thanks,

-Lei (I don't know why the forum automatically change my name "Lei" to "she", another weird thing.)

louv

Staff

Joined:

Jun 23, 2011

Re: Contour plot weird problem

Hi L.

I may have found the problem. I added a new column (Column 4) that was just Column 2 * 1,000,000,000  and I was able to obtain the contour plot.

11075_Screen Shot 2016-02-25 at 11.55.41 AM.png

guleiss

Community Trekker

Joined:

Feb 23, 2016

Re: Contour plot weird problem

Hi Lou,

Interesting, I did what you said. It worked. Maybe the original column 2 value is too small? anyway, I also submitted the question to JMP technical support. Before getting reply from them, your method worked pretty well.

Thanks,

-Lei

danschikore

Staff

Joined:

Sep 21, 2012

Re: Contour plot weird problem

Hi Lei,

Contour Plot computes a triangulation of the data as a basis for doing the interpolation for contours.  It looks like the triangulation step is failing in this case due to the different scales for X & Y.

There is an option under the red-triangle menu for "Transform", with two options.  The default is None, and it will triangulate without any scaling of the data.  If you change this to "Range Normalized", each axis will be scaled independently prior to the triangulation, and this appears to resolve the issue for this example.

Changing the Transform can sometimes cause changes in the contours (due to changes in the triangulation), but in this case with data specified on a grid there should be no difference.

-Dan