Subscribe Bookmark RSS Feed
Justin_Chilton

Joined:

Aug 27, 2015

Custom Add-In Builder

UPDATE:  Check out my new Add-In Manager add-in that provides everything from Custom Add-In Builder along with many new features.

If you create a lot of add-ins by zipping up a source folder and changing the file extension to jmpaddin, you might find this add-in to be very useful. If you do not know what I mean by creating an add-in this way, check out Jeff Perkinson's Blog post about this method.

Basically, this add-in very quickly does the process of zipping up your add-in source files into a JMP Addin (.jmpaddin) file. There is the ability to save the information about an add-in so that you can easily build any add-in later on.

I find this to be extremely useful when I need to make incremental changes to an add-in. It allows you to quickly take a change that you made in your source files and easily test that change as an installed add-in.

Custom Add-in Builder ScreenshotCustom Add-in Builder Screenshot

This add-in does not delete or move any of your files except that, when building an add-in, it will overwrite your .jmpaddin file, if it already exists.

See the attached PDFs to see how it works and how you can get started using the add-in.

Comments
nathan-clark

I LOVE this addin! I use it all the time. Two updates that would be awesome would be changing the default table location to be outside of a specific JMP version (I routinely operate in two versions of JMP) and being able to build more than one addin at once.

 

I was actually looking into learning to build something like this via python when I was shown this, so I'm super excited about it! - Thanks :)

vishwasanj

Hi Justin,

I just have 1 script with a .jsl filr. The .def and .cust files were developed. I used the addin builder to create the addin file. I installed it and I could see the addin in jmp toolbar.

When i click on it, my script  runs, it calls the user to choose a file but it stops after that. It doen't do the computation.

When I run the script alone, everything works fine.

Am i missing anything in my addin/script?

Thank you

nathan-clark

@vishwasanj, have you tried building the addin manually? You should be able to just add the files you need into a .zip file and then rename the zip file .jmpaddin. It should give you the same installation.

If that works and the addin builder does not it could be that where you are pointing the addin builder to make the addin from isn't quite correct.

You can also open an addin file with a zip reader to ensure that all the files are correct in the .jmpaddin file.

vishwasanj

Yeah. It is pretty weird. Basically in my script, when you run, it asks the user for the file1 and then the file 2. Once the user give both the files, it merges the file and spits out graphs in the designated folder.

 

If I just run it as a script I have no problem.

But after creating the JMP addin, it stops right after concatenation of the 2 tables. It doesn't get into the associative array of the final table and do the computation.

I have the addin.def, addin.jmpcust and the .jsl file in the folder.

 

I have been having this trouble of setting up the addin feature for the past couple of weeks. I did the manual set up also, it didn't work. I am using JMP 13. Is there any bug? I really appreciate any help.

 

Thank you.

nathan-clark

Have you tried to build the addin yourself outside of the addin builder? Is there an error in the log when you try to run the addin from the addin menu?

Justin_Chilton

vishwasanj,

It sounds like the issue you are having is unrelated to the add-in in this post. I would reccommend creating a new discussion question with details about what your script is doing and exactly what is not working when creating an add-in.

Thanks,

Justin

Article Labels
Article Tags
Contributors