Choose Language Hide Translation Bar
Highlighted
PedeGe
Level II

copied frame content disappears when reopening graph or JMP datatable

Hi,

I would like to receive some help with the following issue:

 

Whenever I make a graph using the graph builder any copied frame content from another frame or graph will disappear when I perform the following actions:

-reopen the final saved graph

-reopen my datafile/session that I stored after finalizing the graph

 

Is there any non-scripting/JSL way to save the graphs together with the copied frame content?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Thierry_S
Level VI

Re: copied frame content disappears when reopening graph or JMP datatable

Hi,
At the best of my knowledge, saving a Graph Builder script to the data table does not capture "manual" modifications such as copy/paste, hence the loss of these modifications. I would recommend exploring building a JSL script to produce the desired effect but I have to admit that I do not have the time nor skills to provide a ready to use solution.
Sorry for not being more helpful.
TS
Thierry R. Sornasse

View solution in original post

4 REPLIES 4
Highlighted
Thierry_S
Level VI

Re: copied frame content disappears when reopening graph or JMP datatable

Hi,
Would it be possible to share the step by step process that leads to your problem. Are you copying the content of frame onto another Graph Builder plot or are you copying into another application? When you say that the copied element(s) disappear upon reopening the saved graph, do you mean that these elements are lost in the GraphBuilder script saved into the table or is it something different?
Best,
TS
Thierry R. Sornasse
Highlighted
PedeGe
Level II

Re: copied frame content disappears when reopening graph or JMP datatable

Hmmm, somehow my reply yesterday never got posted, so here it is again:

 

Thanks a lot for trying to help me out!

 

My aim is to copy the red data points in column B to columns C-E.

These datapoints generally are baseline/reference data that I want to include in other graphs for easier visual inspection.

What I do is the following:

I set the graph settings in such a way that I have one subgraph with just the (red) datapoints that I want to appear in the other subgraphs.

   -sometimes this subgraph is visible in the active graph that I am building

   -sometimes I make it in a seperate graph builder window (but always from the same datatable)

After I am happy with how the datapoints are visualized (color/symbols) I copy the content of the frame to the frames that I want it to also appear in.

After that I save the script of the graph to the datatable.

Whenever I open this saved script the copy/paste action on the frame content have disappeared.

This also happens when I save my current session with the graph builder window still opened-> after opening the saved session the graph builder window is still open, but the copy frame content actions are removed.

 

How could I tackle this issue?

Highlighted
Thierry_S
Level VI

Re: copied frame content disappears when reopening graph or JMP datatable

Hi,
At the best of my knowledge, saving a Graph Builder script to the data table does not capture "manual" modifications such as copy/paste, hence the loss of these modifications. I would recommend exploring building a JSL script to produce the desired effect but I have to admit that I do not have the time nor skills to provide a ready to use solution.
Sorry for not being more helpful.
TS
Thierry R. Sornasse

View solution in original post

Highlighted
PedeGe
Level II

Re: copied frame content disappears when reopening graph or JMP datatable

thanks for this clarification.
I was fearing this was the case.
Hopefully my JSL scripting skills will increase soon so I can automate this procedure.
Article Labels