Choose Language Hide Translation Bar
Highlighted
Jaz
Jaz
Level V

Why do my Invisible Data Tables Appear After Opening

Hi,

 

I have a script in which I open my data tables using open(file, invisible), and then manipulate the file. This used to show the files in the home window but that doesn't seem to be working anymore. When I change it to private the files show up in the homw window but isn't it supposed to be the other way around? Also, when I remove the Import Settings the invisible seems to work just fine, can anyone see what I'm doing wrong?

if(z == "Multiple", 
	dt = Open(x, invisible,  
		Import Settings(
			Column Names Start( 2 ),
			Data Starts( 3 )
		)
	), 
	dt=Open(x, invisible,  
		Import Settings(
			Column Names Start( 2 ),
			Data Starts( 3 )
		)
	)
);

 

 

 

5 REPLIES 5
Highlighted
Jaz
Jaz
Level V

Re: Invisible Data Tables not Visible in Home Window

@txnelsonI'm using the same data tables as in my last post.

 

Highlighted

Re: Why do my Invisible Data Tables Appear After Opening

I run this script and watch the Home window. It behaves as expected.

 

Names Default to Here( 1 );

dt = Open( "$SAMPLE_DATA/Big Class.jmp", Invisible );
Wait( 3 );

biv = dt << Bivariate( Y( :weight ), X( :height ), Invisible );
Wait( 3 );

biv << Close Window;
Wait( 3 );

Close( dt );

dt = Open( "$SAMPLE_DATA/Big Class.jmp", Private );
Wait( 3 );

biv = dt << Bivariate( Y( :weight ), X( :height ), Invisible );
Wait( 3 );

biv << Close Window;
Wait( 3 );

The first have I see the data table name in a light gray font. In the second half it does not appear at all. The platform appears in both parts as a light gray font.

 

Learn it once, use it forever!
Highlighted
Jaz
Jaz
Level V

Re: Why do my Invisible Data Tables Appear After Opening

Okay, but I used invisible and then Import settings in a loop with multiple files, then I add the files to a list to concatenate the files but it says 'cannot locate files in list', and the invisible functionality doesn't work.

Highlighted
Jaz
Jaz
Level V

Re: Why do my Invisible Data Tables Appear After Opening

Is my syntax from the first post wrong? The invisible funcionality works when I get rid of the Import Setttings.

Highlighted
Craige_Hales
Staff (Retired)

Re: Why do my Invisible Data Tables Appear After Opening

there is nothing obviously wrong with your syntax. This works in 13 and 14; invisible makes a hidden window that shows up grayed in the list; private does not make a window at all and nothing shows up in the list.

 

x=savetextfile("$temp\x.csv","junk\!naaa\!n1\!n2\!n3");
dt = Open(x,
		 invisible,  
		Import Settings(
			Column Names Start( 2 ),
			Data Starts( 3 )
		)
	);
	
	close(dt,nosave)

what version of JMP are you using? I'm not familiar with the error 'cannot locate files in list'; what function are you calling that says that? what is the parameter to that function?

Craige
Article Labels

    There are no labels assigned to this post.