Subscribe Bookmark RSS Feed

Schedule JMP Scripts to run Automatically in Windows 10.

ivan_j_moore

Community Trekker

Joined:

Nov 24, 2014

I currently (Using Windows 7 and JMP 13) run a few scripts each morning using the windows scheduler, which works a treat.

I now have a new computer which has Windows 10, when I run the same scheduler, it opens the JSL script but will not run automatically.

 

Does anybody have a simple soluation to this problem ?

 

3 REPLIES
David_Burnham

Super User

Joined:

Jul 13, 2011

What do you mean by "it opens the JSL script"?  What application is being invoked to open the script, is it JMP or just some form of text editor?

 

If if is not JMP then that would suggest a problem with file associations.  If it is JMP, then I'm not sure why a change from Windows 7 to 10 would make a difference but you could try putting "//! " at the beginning of the script (this instructs JMP to run the script when it is "opened" - for example:

example_autorun.PNG

-Dave
ivan_j_moore

Community Trekker

Joined:

Nov 24, 2014

Hi David, 

Thanks for the reply, when I say opens the script, I mean it opens the script in a JMP window but the script does not kick off and Run, 

adding //! does not seem to work either.

As a work around I have done the following which seems to work. Enabled this in File, preferences, Windows Specific, see attached for details.

This seems to run the script when opened by the windows scheduler in Windows 10, dosen't seem to make any difference if this is clicked or not in WIndows 7, wierd !!

 

Capture.PNG

Byron_JMP

Staff

Joined:

Apr 26, 2012

I ran into something like this a while back. I can't find/remember the fix but I think it was an option in Scheduler that I had to change.