Choose Language Hide Translation Bar
Highlighted
Kami
Level I

JMP does not show on Microsoft Excel

I just downloaded the JMP 14 but JMP does not show up on my microsoft excel as it should. As a result, I have to upload my data from excel by going to File --->open ---> upload my excel file ---> Import. How can I get that short cut to have the JMP showing up on excel so I can simply copy my excel data and paste it onto a new window in JMP?

4 REPLIES 4
Highlighted

Re: JMP does not show on Microsoft Excel

Kami,

 

Per the JMP System Requirements, JMP 14's Excel Add-In, will work with Office 2010, 2013 and 2016.  We have done some testing with the newer version of Excel and it appears to work correctly with it as well.

 

That said, there are two possible reasons the Excel Add-In for JMP is missing. First, the add-in registry enteries are corrupt and need to be repaired, or a recent Office update corrupted the registry enteries.

With JMP closed, navigate to Control Panel > Programs & Features.
Find JMP 14 in the installed programs list. Right-click it and select Modify/Change.
This will open the installation options box. Find the Excel Add-In, if it is checked, you will need to uncheck it, click OK and follow the process. Reboot and do the above again, checking it this time.
If it is unchecked, check it and follow the process laid out above.
If this does not fix it, this means something is not working correctly with Excel. Since this is an Excel Add-In and not a JMP Add-In, we rely on Excel to function properly.
In this case, in the Programs & Features, find Office. Right-click and select Modify/Change. When prompted, select the option to do a Repair.
This process has resolved nearly every JMP Excel Add-In issue I have encountered.

 

If this process does not fix your issue, please put a track in to JMP Technical Support and we will help you resolve the issue.  You can do that HERE.

Highlighted

Re: JMP does not show on Microsoft Excel

Dave had already answered the question, so I removed this reply.

Dan Obermiller
Highlighted
Cutiehouse
Level I

Re: JMP does not show on Microsoft Excel

I had the same problem and found solution by following:

 

On your excel go to

File -> Options -> Add-ins

On the bottom of the menu, you will see "Manage"

Then, select "COM Add-ins" and press Go...

Check both "JMP Profiler Core, from SAS" and "JMP Profiler GUI"

Click "OK."

 

You will see the add-ins on the excel menu now.

Highlighted
cwillden
Super User

Re: JMP does not show on Microsoft Excel

Thank you!  I had JMP Profiler Core checked, but not JMP Profiler GUI.  Once I had both checked, the menu appeared for me as well.

-- Cameron Willden
Article Labels

    There are no labels assigned to this post.