Subscribe Bookmark RSS Feed

Editing columns in graph builder?

natalie_

Community Trekker

Joined:

Jan 6, 2016

I am very new to JMP.  I'm looking through the tutorials, and I don't see how I can edit the columns.

I have opened a csv file and I want to plot two columns in the graph builder.  However, these columns have parts of a header file in it.  How can I only plot the data and not the header file? 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution

You'll need to remove the rows containing header information.  Highlight one or rows to delete by clicking on the relevant row numbers, right-click and select Delete Rows.

If your data is numeric, you'll also need to convert your columns from character type to numeric type.  After removing the header rows, right click on the column name and select Column Info.  Change Data Type to Numeric, and Modeling Type to Continuous.

4 REPLIES
billw_jmp

Staff

Joined:

Jul 2, 2014

Hi Natalie,

Your best bet here is to consolidate your header information into the first row of your csv file, save it and then open it in JMP.  This will eliminate the header information in the first row of the JMP data table. 

Another option is click on row 1 or all the rows that have header information to highlight them it then right click in the shaded area and select delete row(s).  This is assuming you don't need the header information that is in row 1. 

Hope this helps,

Bill

Solution

You'll need to remove the rows containing header information.  Highlight one or rows to delete by clicking on the relevant row numbers, right-click and select Delete Rows.

If your data is numeric, you'll also need to convert your columns from character type to numeric type.  After removing the header rows, right click on the column name and select Column Info.  Change Data Type to Numeric, and Modeling Type to Continuous.

natalie_

Community Trekker

Joined:

Jan 6, 2016

Thank you!

notoriousapp

Community Trekker

Joined:

Jun 4, 2014

@natalie_ In the future, you can simply import the data so you're column headers are not in the first row of your data table.  You may want to read this overview in importing data into JMP: Getting Your Data into JMP

I also like a lot of the short youtube videos that JMP puts out.  Here's one in importing data into JMP:  Importing Data into JMP, Opening files in JMP, Stacking Data, Sorting Data, and Splitting Data - You...