Subscribe Bookmark RSS Feed

Attaching Data Table to Report

Hi Group,

As a new JMP user, I have a basic question: it seems that sometimes when I save a report (e.g., results of a linear model) JMP asks if I want to attach the data, but other times it doesn't. (I'm pretty sure I was saving a JRP file each time.)

Sometimes the JRP file is large and appears to include data, but other times it is just a script. Is there a reason for this?

Is it indeed possible to attach a file to output results, and if so, how?

Thanks,

John
5 REPLIES
I think I've found the answer. In some cases U opened JMP first and imported data from a SAS dataset. Then when I saved the report it asked if I wanted to embed the table in the .JRP file.

However this apparently isn't an option (?) if you get data from a saved JMP data table. (But why? If JMP has the ability to embed data in a JRP file, couldn't this be done generally, regardless of where the data originally came from?)
mpb

Super User

Joined:

Jun 23, 2011

Based on a few examples I tried I think the following is what happens:

If the data table has been changed for any reason (either before or after the report has been run) but not saved, then JMP asks you whether you want to save the changed table or embed it in the report. In the first case JMP saves the table and saves the report script separately. In the second case JMP saves them together.

Michael
Hi Michael,

Interesting... I wonder if something like re-sorting would constitute an actual "change" to the data.

There appears to be something funny happening with selecting rows. JMP seems to remember which rows are selected when you save a data table. When you read the table back, the same rows are selected/unselected. Yet if you change the selection (e.g., unselect all rows), then JMP doesn't interpret this as a change
(e.g., if from the File menu, "Save" is not available, although "Save as" is.)

John
I have read the thread, and have a similar, but different problem:

Several of my team members have commented that they have been unable to open jrp. files that have been shared via Lotus Notes. In both cases, the originator of the jrp file has been able to open it when asked.

I did some tests where I opened a jmp data file, created a report, saved it, then tried to reopen it.

The first time, it reopened successfully. Then I deleted the jmp data file and tried to open the jrp file that had been created from it. The jrp file would not open!

It appears that jrp files can only be opened if the jmp file is available, which would explain why those receiving the jrp file via Notes were not able to open it.

What is the best way to resolve this problem?
Is there a way to save the jmp file as part of the jrp file?
Could the jrp file be read if the savers or openers preferences were different?
Should we be sharing jrn journal files instead of jrp files?
Other????
mpb

Super User

Joined:

Jun 23, 2011

You can save the report to the data table using Script>Save Script to Data Table and then send the data table. If you want the report to run automatically when the table is opened by the recipient then name the script OnOpen. As you mentioned you can journal the report and send that around but then the report is not "live".