Why not simplify naming in JMP and call the Cp and Cpk values as "capability" and the Pp and Ppk values as "performance", i.e. drop the term "overall sigma capability"? Since Pp and Ppk are estimates of past performance based on the descriptive statistic "overall SD" it seems to me misleading to label them as "capability".
I think it would be helpful to have capability more clearly aligned to stable/ predictable processes i.e. "within sigma" and leave the Pp/Ppk values as simple (and often useful) descriptions of past performance.