Subscribe Bookmark RSS Feed

Pasting in data when column data types are different

jennifer_n_blak

Community Trekker

Joined:

Jan 25, 2016

Hello!

  I am trying to paste into a preexisting data table an updated row of data from excel.  The problem is, I've been working with the data already in JMP for several days and made changes to column properties, etc.  Now, even though the old and new data will line up perfectly by column, I continue to get an error message from JMP, saying that "Data types of destination columns and source columns are different."

 

How do I override this and coerce the data types in the new row to the old format?

 

Thank you for your help!

Jennifer

 

P.S.

I've already tried these tactics:

pasting directly from excel

creating a new data table in JMP and then pasting from there

 

Although I could concatenate this in, I think there must be a simpler way! Cut and paste is early 90s technology...

3 REPLIES
txnelson

Super User

Joined:

Jun 22, 2012

Your issue is undoubtedly that the one or more of the JMP columns you are attempting to copy into are numeric, and the data you are attemping to paste into that column are not numeric in form, or at least JMP does not think it is.  Without seeing an example of the data in question, I can only guess at a solution.  

Many times, if you are attempting to paste in a Time or Date value, and you can have a conflict if in Excel, the values are in a text string, and in JMP you have them in a numeric Date/Time structure.  You can fix this copy/paste issue, by changing the "Informat" in JMP to expect the data in the text format specified in Excel.

If the data are invalid-to-JMP values, you will have to copy them into a new data table, then change the column data types, and then either do a concatinate or an Update to put the data together.

Jim
jennifer_n_blak

Community Trekker

Joined:

Jan 25, 2016

Dear Jim,

   Yes, the issue is that although every column is numbers, JMP brings everything in as character data.  It takes me a long time to get all the columns reading the correct way.  So when I need to input a new row, it reads as character once again, and won't allow pasting into numeric columns. This is not a time or date issue.   I will try the update function that you mention.  Could you tell me how to go about changing

I will try the update function that you mention.  Could you tell me how to go about changing the "informat" in JMP?  I am not familiar with this option, but it sounds like what I was hoping for.  

Thanks for your help!

Jennifer

txnelson

Super User

Joined:

Jun 22, 2012

If you are cutting and pasting from Excel to JMP and the data in the Excel spreadsheet is in Text format, but are actually valid numeric values, JMP(13.2.1, 12.2.0) will interpret the values correctly and display the values as numeric in JMP.  The informat is for the conversion of Excel Text fields such as dates or times, that need to be converted to numeric values in JMP.

The Informat is specified in the Column Info for a column.

 

Could you provide a sample JMP data table, and a sample Excel spreadsheet so I could investigate this issue further?

Jim