Subscribe Bookmark RSS Feed

How to Maintain JMP legend layout when copying and pasting graphs into Word/PPT?

Tritonx4

New Contributor

Joined:

May 25, 2017

Since updating to JMP 13 I have not been able to maintain legend formatting when copying a graph into word or powerpoint. Attached is an example of how in JMP the legend will be formatted how I prefer and then after copying and pasting into word the legend usualy reverts to containing every possible item in the legend instead of only the items I selected.

 

Thoughts on what might be going on?

  legend formatting.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
Tritonx4

New Contributor

Joined:

May 25, 2017

Solution

For what it is worth to anyone else experiencing the same, it seems that this issue does not happen when I right click on the graph with the arrow cursor and select "edit > copy graph". Using that method the legend displays as it appears in JMP. However, if I use the selection tool to highlight what I intend to copy (what I had been doing) or use any of the other methods highlighted above the legend does not display as it appears in JMP. Thanks again for the timely responses!

4 REPLIES
Dan_Obermiller

Joined:

Apr 3, 2013

I might be missing something, but I do not see a legend on your graph (either one!).

The top picture is of graph builder, and all of the items to the left of the graph are part of the control panel, not the graph. When you are finished creating the graph, you click DONE. The result is what is copied because that is the graph.

 

Some tips on copying/pasting to Microsoft Office products: when you select the items in JMP and choose Copy, use the Paste Special option in Office and choose the Enhanced Metafile. That seems to give the best results as the Windows clipboard is notoriously "unfriendly" on what it will do with copied items. Further, you could take your JMP report and save it directly as a Word document or a PPT document. That might be a good way for you to work, too.

Dan Obermiller
Tritonx4

New Contributor

Joined:

May 25, 2017

Hi Dan,

 

Thanks for the response. The legend I am referring to is below the graph and is titled "Days Online Segmentation". In the top figure it doesn't have the markers in the legend but then when copied into word the markers show up. I tried pasting in the metafile but this didn't seem to help. Appreciate any other insight you might have.

Dan_Obermiller

Joined:

Apr 3, 2013

Have you tried saving them into the desired file format? In general I have always disliked what the Windows clipboard does with copied images. Perhaps you will have better luck saving directly to PPT or Word.

 

Also, if you are going to want SEVERAL images to go to PPT or Word, try journaling each picture as you create it. You can then save the journal in PPT or Word format.

Dan Obermiller
Tritonx4

New Contributor

Joined:

May 25, 2017

Solution

For what it is worth to anyone else experiencing the same, it seems that this issue does not happen when I right click on the graph with the arrow cursor and select "edit > copy graph". Using that method the legend displays as it appears in JMP. However, if I use the selection tool to highlight what I intend to copy (what I had been doing) or use any of the other methods highlighted above the legend does not display as it appears in JMP. Thanks again for the timely responses!