Subscribe Bookmark RSS Feed

Date does not replicated into JMP from Excel

tohalan

Community Member

Joined:

Jul 5, 2016

Hi All,

Need help !

Not very familiar with JMP & still learning

After copy the data from excel & pasted into JMP, the date cannot get it correctly.

Anyone can help to guide me ? Thank you

2 REPLIES
gail_massari

Community Manager

Joined:

Feb 27, 2013

Are you in Singapore and your Excel defaults are set as follows?  If so, try my suggestion below.

11950_pastedImage_0.png

I believe that when you use the JMP Add In for Excel to open the Excel data as a JMP table, JMP is not recognizing the local English Singapore date settings.  It is converting any dates beginning with 13 (which is not a month in the English US format mm/dd/yyyy) to the default mm/dd/yyyy.

IN JMP>PREFERENCES>WINDOWS SPECIFIC, examine the setting below.  The locale settings for your operating system normally determine settings for number, date, and currency formats. So, if checked, try unchecking it. 

11951_pastedImage_1.png

Alternately, instead of using the Add-In for Excel, you can try explicitly opening the file from JMP using FILE>OPEN.

Steven_Moore

Super User

Joined:

Jun 4, 2014

Another way to do this is to make sure your Excel column of dates is formatted as "short date".  You do this in the Home tab.  Highlight your column of dates.  Then in the drop down menu of the "Number" section, select "Short Date".  The dates will copy over to JMP nicely.

Steve