BookmarkSubscribeRSS Feed
DonMcCormack

Staff

Joined:

Jun 23, 2011

Advanced Mastering: Fitting Repeated Measures Data with JMP Pro

Resources from the Fitting Repeated Measures Data with JMP Pro webcast are based on my Discovery Summit Europe 2017 presentation.  Use them to try the techniques demonstrated in the webcast.. 

Comments
bio_grad

 

 Hi Don, many thanks for the presentation and information - very useful!

 

I tried to apply the "Repeated Measures Utilities.jmpaddin" to the sample short-wide FEV1 data attached but I am receiving the following error:

 

"argument should be number of character in access or evaluation of 'Num', Bad Argument( timeList[i] ), Num/*###*/(timeList[i])"

It looks like it is trying to convert the columns to Numeric, but the column names are character type. Wondering if there might have been any modifications made to get the example in your presentation working.

 

Particularly this section of the code:

 

runOK = Expr(
	timeList = dialogRef[List Box Box(1)] << Get Selected;
	For(i=N Items(timeList),i>=1,i--,
		If(Column(tblRef,timeList[i]) << Get Modeling Type != "Continuous",
			Remove From(timeList,i)
		)
	);
	If(N Items(timeList) > 0,
		numTimeMat = [];		
		for(i=1,i<=N Items(timeList),i++, numTimeMat = numTimeMat |/ Num(timeList[i]));

		If(Sum(Is Missing(numTimeMat)) == 0, 
			newSortOrder = Rank(numTimeMat);
			timeList = timeList[newSortOrder];
		);

 

 

 

Thanks!

 

 

DonMcCormack

Can you give me a bit more detail, I can't seem to recreate this problem. Using the unstacked data, select Make Correlation/Covariance Graph. The dialog box should only show you numeric columns. Select the columns Hour 1 though Hour 8 and click OK. When I do this, it generates the correct graph. If you're getting something different, please let me know. It would be also helpful to know which OS you're using and what version of JMP.

Thanks, Don

bio_grad

Hi Don,

 

I am running JMP Pro 13.0.0 on Windows 7.

 

I am using the unstacked FEV1 data and selecting the "Make Correlations/Covariance Graph" add-in.

 

Below are screen captures of what I am seeing on my end, along with the error.

 

01_select_addin.png02_select_columns_and_error.png

DonMcCormack

Not sure what's going on. I'm doing the same thing and get the correct results. How recently did you download the addin? It's possible the first version had this bug. Also, try closing and restarting JMP. Sometimes the add-ins don't work properly until this is done. Are you using JMP 13.2.1? Let me know if any of this works.

bio_grad

Hi Don, I downloaded the addin earlier today.

 

Just got it to work - looks like updating to 13.2.1 fixed the issue. Thanks for the help!

DonMcCormack

Glad this solved the problem.

Article Labels
Article Tags
Contributors