BookmarkSubscribe
Choose Language Hide Translation Bar

want the fit model coefficients to be in [0,1]

Hi !

I want the all fit model coefficients to be in [0,1]. Is there a way to set that in JMP?

Thanks in advance !
0 Kudos
4 REPLIES 4
mpb
Super User mpb
Super User

Re: want the fit model coefficients to be in [0,1]

You might try using the nonlinear fitting platform. It lets you place bounds on the parameters which, in this case, would be the coefficients in your linear model.
0 Kudos

Re: want the fit model coefficients to be in [0,1]

Thanks for this idea, I can't however find a way to place the bounds for a parameter ? Could you please explain how you manage to do that?
0 Kudos
mpb
Super User mpb
Super User

Re: want the fit model coefficients to be in [0,1]

I am using version 8.0.2 on Windows XP.

In the nonlinear fit dialog, enter the column containing your Y values and for X the column containing a formula with parameters. Click OK. On the dialog which then displays, click on the red triangle next to "Nonlinear Fit" at the top of the dialog and choose "Parameter Bounds" which is the first choice on the pull down list.
0 Kudos
Highlighted

Re: want the fit model coefficients to be in [0,1]

It works, thanks a lot !
Do you think there is a way to impose the fact that the sum of all coefficients will be 1 ?
0 Kudos