Subscribe Bookmark RSS Feed

problems printing

joe_clearsign_c

Community Trekker

Joined:

Feb 27, 2015

I have had this problem for many years with JMP.  Basically, it will not allow me to adjust text in any meaningful way when I print .  Everything wants to print out on 8-1/2 x 11" paper.  Even when I output to a printer that has 36" roll paper, I can't get meaningful scaling, have no control over pagination, etc.  The only workaround that I have found is to copy the output as a jpg and dump it in Excel.  Use Excel to adjust pagination and run the printer drivers from there.  Is there a reason that the printer dialog box in JMP doesn't  give me normal options for scaling and adjusting paper size similar to every other program I run on my Mac?  Even when I go to the page layout dialog, it doesn't work.

I am using JMP 11.2.1 on a Mac Air but this has been a perennial problem for many years for me on either PC or Mac environments.

3 REPLIES
julian

Staff

Joined:

Jun 25, 2014

Hi Joe,

Sorry to hear you're having issues with printing! Each platform you enter maintains its own page setup properties, so after you get an output you like, but before you print, go to File > Page Setup. Next, you will need to set up a custom paper size, if you haven't already, for your plotter. Next to "Paper Size" select "Manage Custom Sizes…"  I often like to save very large outputs (like from multivariate) to a single page PDF, so I made myself a "Poster" size layout (36x48).

8188_Screen Shot 2015-02-28 at 7.55.59 PM.png

Once you've done this, click OK, and make sure your Paper Size section is set to your custom paper size, then click OK. Now that you've set your paper size, when you go to File > Print, you will see your layout on the custom paper size.

8189_Screen Shot 2015-02-28 at 7.57.44 PM.png

This is handy not only for printing, but also if you want to stop large output from wrapping in a PDF.  Do note that when you go to another platform it will not automatically select your new paper size, but rather defaults back to whatever is set in your system preferences as the default paper size for your printer. To change that, go to System Preference, Print & Scan, and then select your printer and change the default paper size. JMP will honor as its default whatever is set in your global system preferences.

I hope this helps!

julian

joe_clearsign_c

Community Trekker

Joined:

Feb 27, 2015

Sorry for my late reply Julian, but I've tried this many times.  The 8-1/2 x 11 page just gets expanded to to 36" wide.  I get no additional content, just a larger typeface.

julian

Staff

Joined:

Jun 25, 2014

Hi Joe,

That's really strange! Changing the page size shouldn't affect the size of objects, just the size of the canvas/workspace. I'm sorry to hear this isn't working for you. Have you tired e-mailing support@jmp.com? They might have additional suggestions to get this working for you.

Julian