Subscribe Bookmark RSS Feed

get column properties() -> changed behavior?

matteo_patelmo

Community Trekker

Joined:

Dec 23, 2015

Hello, I've upgraded recently to JMP Pro 13.2 from release 12.2. 

 

The following simple script applied on a data table with just an empty column1 with some properties set creates a second column and copies the properties from column1 to column2.

 

dt= current data table();
dt<<add rows(1);
c=column(1);
p=c<<get column properties();
c2=new column("column 2");
c2<<add column properties(p);

 

 

It used to work on 12.2, but it does not work on 13.2.  Variable p cointains the same expression, but "add column properties" will not add any property to column2 in version 13.2.

 

Did anyone out there notice this changed behavior? Which version introduced this change (13.0, 13.1, 13.2)?

 

thanks in advance


Matteo

2 ACCEPTED SOLUTIONS

Accepted Solutions
txnelson

Super User

Joined:

Jun 22, 2012

Solution

I have validated your findings between 12.2 and 13.2.1.  You need to get this to 

     support@jmp.com

Jim
matteo_patelmo

Community Trekker

Joined:

Dec 23, 2015

Solution

Hi Marvin, yes they suggested using eval(eval expr(... expr(p))) as 

workaround.

 

 

bye

matteo

4 REPLIES
txnelson

Super User

Joined:

Jun 22, 2012

Solution

I have validated your findings between 12.2 and 13.2.1.  You need to get this to 

     support@jmp.com

Jim
matteo_patelmo

Community Trekker

Joined:

Dec 23, 2015

thanks Jim. I will certainly do so.

Matteo
mkennke

Community Trekker

Joined:

Mar 18, 2016

Hello,

 

did you got an answer? I have the same Problem.

 

Regards,

Marvin

matteo_patelmo

Community Trekker

Joined:

Dec 23, 2015

Solution

Hi Marvin, yes they suggested using eval(eval expr(... expr(p))) as 

workaround.

 

 

bye

matteo