Subscribe Bookmark RSS Feed

What is wrong with my XY map file?

simonp

Community Trekker

Joined:

Feb 24, 2012

Hello all,

I am having difficulty with map shape files and I hope you can help. Please see attached 7z file which contains both CanadaFSA-XY.jmp and CanadaFSA-Name.jmp. Basically, I had followed the directions on the tutorial video and blog, and set up the files but for some reason I am getting an error and the graph builder refuses to display the map when CanadaFSA column from CanadaFSA-Name.jmp is pulled to Shape area. The error message in the log is:

Map XY data file, "/Library/Application Support/JMP/9/Maps/CanadaFSA-XY.jmp", does not contain the necessary columns.

I cannot seem to figure out what the issue is. Please help!

Thank you very much in advance.

Patrick

1 ACCEPTED SOLUTION

Accepted Solutions
Solution

The XY file should have 4 columns: Shape ID, Part ID, X, and Y. You're missing Part ID. If every shape has only one part, you still need a Part ID column, which can be all 1s.

2 REPLIES
Solution

The XY file should have 4 columns: Shape ID, Part ID, X, and Y. You're missing Part ID. If every shape has only one part, you still need a Part ID column, which can be all 1s.

simonp

Community Trekker

Joined:

Feb 24, 2012

Thank you very much for your help and clarifying. The original file did not have part ID in it, and upon adding all 1s, JMP kept saying the file was corrupt. So I obtained a different file which now contains all necessary items and JMP has no problem opening it. I assume it is your experience that told you the Part was missing from the file or is there anything in the Log file that I could use in the future to figure out what the problem was?

An unrelated question: My JMP knowledge is limited so I could have missed it, but how would I add multiple shapes/layers on the same graph (say a map of postal codes (1st layer), cities (2nd layer) and add labels for each shape? Is this possible?

Thank you!!!!

Patrick