Subscribe Bookmark RSS Feed

Validation Column Creation

Steven_Moore

Super User

Joined:

Jun 4, 2014


I have tried using the Make Validation Column function under Modeling Utilities.  However, this creates a column that is not made up of integers.  The recursive partitioning works OK with this, but neural networks don't like the fact that integers are not being used in the validation column.  I suppose "Training", "Validation", and "Test" can be recoded, but this takes several extra steps that should be unnecessary.  Can this be corrected in the next revision of JMP Pro 12?

Steve
7 REPLIES
scwise

Staff

Joined:

Jul 7, 2014

smoore2,

There is an older method for making a validation column that first puts integers into the column. 

Simply go and create a new column in your JMP datatable.

Then double click in the header an go into Column Info.

Since there is no new data in the column, you will see an option for Initialize Data.

Select Random, then Random Indicator from the dialog box and put in the proportion of cross validation splits that you want.

This will return a new column you can use for cross validation with only integers initially given.

You would have to recode or use value labels to get a label associated with it.

See my screenshot to see it in action.

Hope this helps out!

- Scott

9230_Screen Shot 2015-07-15 at 10.34.19 AM.png

louv

Staff

Joined:

Jun 23, 2011

Not sure I understand the problem. The Modeling Utilities have Value Labels in the Column Info.

Are you sure you populated the Validation in the dialog box?9231_Screen Shot 2015-07-15 at 10.37.04 AM.png

Steven_Moore

Super User

Joined:

Jun 4, 2014


Lou,  I did populate Validation in the dialog box, but I get an error message ("Validation column must contai only integer values and cannot have any gaps within its range.")  Hitting OK to this message leads to another message that the neural netowrk will attempt its own random partition of the data.  That's OK, but no "test" results show up.

Steve
Dan_Obermiller

Joined:

Apr 3, 2013

I am a little confused. To preface this, I am using version 12.1 of JMP Pro. I choose Cols > Modeling Utilities > Make Validation Column. I get this dialog box:

9236_pastedImage_0.png

I click on Purely Random to create a new column called Validation. The Column Info on that column is this:

9237_pastedImage_1.png

The Validation column contains only integers. The Value Label makes it appear as text, but they are integers. Regardless of how I have tried using this utility, I am always getting a column of integers.

Your question implies that you are getting a column of all random numbers that include non-integers. Could you be more specific on the steps that you are taking?

Dan Obermiller
Steven_Moore

Super User

Joined:

Jun 4, 2014

it seems to work now that I uncheck the "Use Value Labels" box at the bottom of "Column Info".  Perhaps the default should be unchecked instead of checked - more efficient that way - at least for me.

Thanks!

Steve
Steven_Moore

Super User

Joined:

Jun 4, 2014

Nope!  Still get the error message even though I now see integers in the column.

Steve
Dan_Obermiller

Joined:

Apr 3, 2013

I am afraid you may need to contact Tech Support. Providing a column of integers as a validation column to Neural Network should work. I do not even need to turn off the Value Labels checkbox and Neural works just fine. I think you may need to be prepared to provide them with more details, such as version of JMP, how you completed the Modeling Utilities dialog box, does this problem occur with other data tables, and possibly even some data that illustrates the problem.

Dan Obermiller