Subscribe Bookmark RSS Feed

Unresponsive when hovering over a variable containing an associative array... how to disable?

kardopaska

Community Trekker

Joined:

Feb 24, 2016

If I have a fairly large Associative Array that I'm working with in the script editor, and I hover my mouse over it, JNK will try to show me a tool tip containing the contents of the variable.  Other large things like matrices and lists are fine to hover over, but hovering over an associative array makes the mouse cursor rapidly change between pointer and hour glass and I can't do anything, even if I move my mouse away.  The larger the array, the longer the wait.

It's even worse when right after i've waited for JNK to do whatever it's doing, that I accidentally scroll over that variable ever so quickly and I have to wait all over again.  The threshold for activating tool tips is way too small.  Try for yourself in script editor...

hover_over_this_with_your_mouse_after_running_this_line = AssociativeArray(Index(1, 100^2));


How can I disable this annoying behavior?  I tried disabling tool tips in preferences and hiding the status bar, but it doesn't work.  Also, please tell me if this isn't reproducible for you. Thanks.

3 REPLIES
ms

Super User

Joined:

Jun 23, 2011

I can't reproduce this. The tooltip shows after about 2 seconds, without the editor becoming unresponsive. Typing or hitting ESC interrupts the tooltip.

I tried 100^2 and 100^3 with barely no difference when it comes to the tooltip (although populating the log was very slow with 100^3).

I use JMP 12.2 on a quite modern Mac.

Craige_Hales

Staff

Joined:

Mar 21, 2013

Yes, JMP 12 fixed this.

Craige
msharp

Super User

Joined:

Jul 28, 2015

I also was unable to reproduce it running JMP 12.2 on Windows 7.