Share your ideas for the JMP Scripting Unsession at Discovery Summit by September 17th. We hope to see you there!
Choose Language Hide Translation Bar
Highlighted
tam3
Level I

Precision column format does not "Keep all whole digits" after re-opening data table

Using JMP 15.0.0, I use a script to set specific column formats and use the Precision format with the option for "Keep all whole digits" checked:

 

column(1) << Format("Precision", Use thousands separator(1), Keep trailing zeroes(0), Keep all whole digits(1), 41, 5);

After applying my script, the column properties for the Precision columns are correct and the data table script shows the formatted columns correctly:

 

Format(
			"Precision",
			Use thousands separator( 1 ),
			Keep trailing zeroes( 0 ),
			Keep all whole digits( 1 ),
			41,
			5
		)

 

However, when I save and reopen the same data table file, the "Keep all whole digits" option is no longer checked and the data table script no longer contains that particular entry at all:

 

Format(
			"Precision",
			Use thousands separator( 1 ),
			Keep trailing zeroes( 0 ),
			41,
			5
		)

No additional scripts are run upon opening the file. The same issue happens when the "Keep all whole digits" is checked, the file is saved, and re-opened. I did not find any options to prevent this within JMP preferences.

 

How do I prevent this from happening?

 

1 REPLY 1
Highlighted
txnelson
Super User

Re: Precision column format does not "Keep all whole digits" after re-opening data table

Sounds like a bug.....I would contact JMP Support @

     support@jmp.com

Jim
Article Labels

    There are no labels assigned to this post.