BookmarkSubscribeRSS Feed
Choose Language Hide Translation Bar
gandi2223
Community Trekker

Open JMP scripts in Windows Explorer without executing them

In the past, when I double-clicked a JMP script in Windows Explorer, it would be opened in JMP. Recently, this functionality seems to have changed, and now the script is executed straight away. I've been trying to find a way to revert to the previous behaviour, but I don't seem to be able to find anything on this in the Preferences. This is on JMP®  12.1.0  (64-bit).

0 Kudos
5 REPLIES 5
txnelson
Super User

Re: Open JMP scripts in Windows Explorer without executing them

Go to

     Preferences==>Window Specific

and unselect

     JSL Scripts should be run only, not opened, when selected from Recent Files of a file browser

You can also stop this behavior by pressing down the CNTL key when selecting from your file browser

It may also be that someone has placed "//!" as the first line.  This will force the running of the script rather than opening it.  Pressing the CNTL key when opening this file will open it rather than running it

Jim
gandi2223
Community Trekker

Re: Open JMP scripts in Windows Explorer without executing them

Hi Jim,

thanks for the prompt answer - that option would have been my first guess, but it is unchecked:

12989_pastedImage_3.png

I didn't place a "//!" at the start of the script either (good to know about this option, however!).

CTRL +  double-clicking in Windows Explorer works, so I will go with this approach. Still curious why the setting in the Preferences doesn't do what it's supposed to though...

0 Kudos
Ryan
Community Trekker

Re: Open JMP scripts in Windows Explorer without executing them

I have been using JMP7 for years and my scripts have always just open as well. Recently I also installed a newer version (JMP10) and suddenly all my scripts try to run when I double click them in Windows Explorer. The setting mentioned is unchecked in both versions, but I cannot get this to stop happening. Did you ever find a solution?
0 Kudos
maor2k
Community Member

Re: Open JMP scripts in Windows Explorer without executing them

Hi,

Did you manage to solve this issue? how can we change it to auto open at script editor?


@gandi2223 wrote:

Hi Jim,

 

Still curious why the setting in the Preferences doesn't do what it's supposed to though...


 

0 Kudos
Ryan
Community Trekker

Re: Open JMP scripts in Windows Explorer without executing them

This got solved for me when I upgraded to a new work computer. Still have both versions of JMP (7 + 10), but now the scripts open without running.

0 Kudos