Subscribe Bookmark RSS Feed

Mapping with Counts

thomash1

Community Trekker

Joined:

Jun 23, 2011

Hi,
Pretty new to JMP - with 9.0 I'm attempting to drag a Country onto the Graph Builder to create a map with a count of customers (CustomerIDs) by Country as an "easy" test. So I would want USA, with the most customers to be, say, dark Red, and countries with less customers a lighter shade. Since the CustomerIDs have no value, I made them nominal and dragged the field to the lower right corner of the Graph Builder grid, under Freq. I thought the shading would magically appear, but nothing happened. Yet when I click on a country it shows each individual CustomerID rather than counts. Simple I'm sure, but I'm stuck.

Thanks,
Thomas
3 REPLIES
thomash1

Community Trekker

Joined:

Jun 23, 2011

More information....I just looked at the values that appeared when I clicked a Country and they don't appear to be CustomerIDs at all -- so not sure what values they are. Also, I am using a 3 character CountryCode in my dataset that I'm assuming is what the Graph Builder is keying off correctly, or it wouldn't be able to build the map.
Jeff_Perkinson

Community Manager

Joined:

Jun 23, 2011

I believe I understand the situation but let me summarize:

You've got a data table with one row for each customer and a column that indicates which country the customer is in.

You'd like a map that's colored by the number of customers in each country.

To get that you'll need a new data table that has one row for each country and a column indicating the number of customers in that country. That's easy to create from your current data, just use Tables->Summary and in the dialog use country as your Group column. Click the okay button and you'll get a table with one row for each country and column "N Rows" that is the number of rows from your original table for each country. Use these two columns in Graph builder, N Rows in the Color role and you'll get the map you want.

I hope that helps. Let me know if you have further difficulty.

Jeff
-Jeff
thomash1

Community Trekker

Joined:

Jun 23, 2011

Thanks Jeff.....this is great -- works fine now!