Subscribe Bookmark RSS Feed

Making Oneway Plots with Histograms

nocaltim

Community Trekker

Joined:

Sep 29, 2014

I am trying to "fix" a problem that did not exist in JMP 10 but is now giving me fits in JMP 11.  When I make a Oneway plot, I like to plot the histogram at the right (which is a simple option to enable).  After I turn on the histogram, I then want to turn off the display of the points used to make the histogram.  There is also an option to do this.  Then comes the problem....Having turned off the display of the plot points, I want to "shrink" the window that formerly held the plot points down a zero width window.  That too is easy to do (set the horizontal width of the window to zero), but it creates bizarre problem:  The category labels are hidden but still exist and they create display problems because those hidden category labels have a non-zero size to them.  This was never a problem in JMP 10, but JMP 11 has this problem and I can't figure out how to get around it.

Anybody have any ideas?

Thanx

9 REPLIES
julian

Staff

Joined:

Jun 25, 2014

Hi nocaltim,

Can you provide a screenshot of the display problem you're experiencing? I just followed your steps in JMP 11.2 and came up with the outputs below.

7353_Screen Shot 2014-09-29 at 10.39.01 PM.png7354_Screen Shot 2014-09-29 at 10.45.13 PM.png

Is there another step I need to follow in order to reveal the display problem? Please let me know and I'll be happy to help you figure out a solution.

Julian

nocaltim

Community Trekker

Joined:

Sep 29, 2014

Hello-

Thank you for the prompt reply. And, I can already see a partially better understanding of my problem from your attempt to replicate. You did the steps correctly to re-create the Oneway plot – except for one detail that I omitted.

In my case, I have, say, 2 or 3 continuous variables such as “Cost” and “Complexity” for which I am trying to make Oneway plots (in the example below, using “Type A” and “Type B” categories for my “DesignType” category variable). Rather than create, say, three separate windows of Oneway plots, I just select all three columns simultaneously and then create a group window where each continuous variable (i.e., Column of data) gets plotted in a Oneway format against the category variable.

The above works fine, until I shrink the points window to zero horizontal width (to leave only the histograms as desired). When I do this, the Oneway plots suddenly space out vertically, as suggested in my screenshot below. And when I go to copy-and-paste them into, say, Power Point, I’ve got a these large figures that I have to manually trim to size.

Now, here’s what’s interesting….If I do a single Oneway plot at a time (i.e., make three Oneway plot windows instead of a group), then the space below the Oneway plot is not affected and the plot figure remains compact.

Any ideas?

Thanx!

julian

Staff

Joined:

Jun 25, 2014

When you change the frame size are you broadcasting your command to resize everything at once? When I broadcast the command to change the frames all at once I get an even more problematic display!

7355_Screen Shot 2014-09-30 at 12.12.57 AM.png

Clearly the histograms are inheriting the frame size change, which isn't necessarily wrong, but certainly isn't helpful. I can report this. But, when I change the frame size one by one, I can get this to work:

7356_Screen Shot 2014-09-30 at 12.12.35 AM.png

I tried this with multiple Ys, and when using a By variable. As long as I do it one by one it seems to work for me.

Julian

julian

Staff

Joined:

Jun 25, 2014

I should add, this worked on 11.2 on the mac, and 11.0 on windows. I wonder if there is something peculiar about those data in particular. I can't see why that would be the case, but does the issue occur on different datasets?

Julian

nocaltim

Community Trekker

Joined:

Sep 29, 2014

Well…No luck.

1. If I try resizing the windows one at a time, I still have same problem, so apparently I can’t replicate that part of your experience.

2. This problem has happened now with every data set I’ve attempted to work with (I only upgraded to JMP 11 a few days ago).

I am left to conclude that if this is not a bug in the software, then it is a most unwelcome “feature.”

Thank you for your help.

julian

Staff

Joined:

Jun 25, 2014

I'm sorry this is happening! There is certainly something peculiar going on here. Out of curiosity, are you on windows or mac? And, have you updated to the newest 11 version, 11.2?

I will try this on some other computers tomorrow. I also saw that your dataset has missing rows, which I usually wouldn't think would affect anything but since the text with the number of missing rows is at the bottom of each frame I thought it might only occur with such a table. But, even with a table with missing rows I wasn't able to replicate that odd spacing. Certainly something strange is happening and I have a hard time letting go of mysteries, so I hope to come back to you with something more definitive.

Julian

julian

Staff

Joined:

Jun 25, 2014

Actually, out of curiously, what happens for you when you change the horizontal frame size to something very small, but not zero, like 1, or even 0.1? When I use 1, I get something close to the spacing issue you have, since all the labels in the original points display are crammed into 1 pixel.  With 0.1 I get the same as 0, probably because JMP is rounding, but I wonder if in your case that would result in something different.

julian

Staff

Joined:

Jun 25, 2014

In the interest of giving you something helpful, perhaps doing this in graph builder would be a useful workaround, assuming a combined plot would work in your situation. I recorded a quick video of setting up that sort of display.

nocaltim

Community Trekker

Joined:

Sep 29, 2014

Hello-

Well, your suggestion to reduce the horizontal frame size to a non-zero positive integer did not fix my problem. But it was a perfect impetus to do something that has created a modestly acceptable solution.

Here’s what I am doing:

1. Select the multiple columns of data and build the Oneway plots against the category. (If I have three data columns, there will be three Oneway plots).

2. On each Oneway plot, manually select the Category Label (below the category titles on the X-axis) and press the delete key to create zero length Category label. (This is not the same as “hiding” the label – which can also be done, but hiding doesn’t fix my problem because the category label is still there in non-zero length).

3. Now set the data points window to zero length.

The vertical spacing between the three Oneway plots is no longer elongated by the hidden category label.

Suggested Fix for JMP: Allow the category label to be DELETED instead of only having the option to hide it.