Subscribe Bookmark RSS Feed

JMP 12 - why does it auto start JSL's?

djhanson

Community Trekker

Joined:

Jun 23, 2011

Ok, I'm running into all sorts of issues trying to run JMP11 scripts on JMP12.  One silly thing, without placing a "//!" on the top line of a JSL by itself, JMP 12 auto runs the script.

 

Anyways, is there a Preference perhaps that I missed for disabling JMP12 JSL Auto Run perhaps?  thanks, DJ

3 REPLIES
djhanson

Community Trekker

Joined:

Jun 23, 2011

I should add I just discovered this:  I've been clicking on the JSL in Windows Explorer, which really should not matter.  But it does.  Using Win 8 if that helps, but again that should not matter.  In this case, JMP 11.1.1 vs JMP 12.2.0.

So when I click on a JSL in Windows Explorer it launches JMP 12 but then always auto runs.  That shouldn't occur.  Can someone else try to validate this perhaps?  Seems like a bug.

 

Click on a JSL in Windows Explorer (no "//!" in JSL's top line):
JMP 11: no auto start (good)
JMP 12: auto start (bad)

Drag on a JSL from Windows Explorer to already Open JMP session (no "//!" in JSL's top line):
JMP 11: no auto start (good)
JMP 12: no auto start (good)

So it's as if something changed with the behavior of the JSL file when using Windows Explorer.  Wonder what changed in JMP 12 to cause this?  DJ

txnelson

Super User

Joined:

Jun 22, 2012

Check to see if the Preferences to autostart JSL files is not selected

     Properties==>Windows Specific==>JSL Scripts should be run only, not opened, when selected from Recent Files or a file browser

 

Also, as a work around, holding down the CNTL key when you select and open the file, will force the script to be opened and not run.

 

If the preferences setting doesn';t fix the issue, it is time to contact JMP at

     support@jmp.com

Jim
djhanson

Community Trekker

Joined:

Jun 23, 2011

Thanks.  Unfortunately, neither one of those solutions work (I did try them though).  DJ