Subscribe Bookmark RSS Feed

JMP 12 to 13, Graph Builder does not color Boxplot outline when using "color"

ccroisetiere

New Contributor

Joined:

Jul 11, 2017

Hi there,

 

In JMP 12, when building boxplot in graph builder, I would normally drag the factor to the "color area" and it will change the outline of the box plot to the color of the marker. It seems that this is not working the same way in JMP 13. I tried to do it with "overlay" which change the color of outline but now the points are not in the boxplot.

 

Please advice,

 

 

CaptureJMP.PNG

CaptureJMP2.PNG

2 REPLIES
ccroisetiere

New Contributor

Joined:

Jul 11, 2017

After more attempts, I cannot reproduce what I was doing in JMP12.

Is there a way to change the "Box plot Element" in the script to the color of outline to fit the marker color defined by my preference?

Graph Builder(
Size( 532, 486 ),
Show Control Panel( 0 ),
Variables(
X( :Onbeads ),
Y( :Final Conc nM ),
Group X( :Volume ),
Color( :Onbeads )
),
Elements(
Box Plot( X, Y, Legend( 5 ), Jitter( 0 ) ),
Points( X, Y, Legend( 6 ) )
)
);
ian_jmp

Staff

Joined:

Jun 23, 2011

Not sure if I have understood your issue. I made this:

Screen Shot 2017-07-14 at 10.38.27.png

by drag and drop (JMP 13.2):

Names Default To Here( 1 );
dt = Open( "$SAMPLE_DATA/Big Class.jmp" );
dt << Graph Builder(
	Variables( X( :sex ), X( :age, Position( 1 ) ), Y( :height ), Overlay( :sex ) ),
	Elements( Points( X( 2 ), X( 1 ), Y, Legend( 4 ) ), Box Plot( X( 1 ), X( 2 ), Y, Legend( 7 ) ) )
);

You can then right-click on the legend and customise further.