BookmarkSubscribe
Choose Language Hide Translation Bar
sadhammer
Community Trekker

How to select single cell when multiple columns are scroll locked?

Greetings,

This is my first post on this forum. For simplicity, I will rephrase my question in the form of an example:

Let's assume I have a large data table (1000 rows by 1000 columns). Columns 1 through 4 are "scroll locked". I am looking at cell [row 500, column 500] and decided I want to copy and paste the value from cell [row 500, column 3] into cell [row 500, column 500]. However, if I single click cell [row 500, column 3], JMP 9.0.1 automatically selects cells [row 500, columns 3 through 500] and "left scrolls" away from column 500 to columns 3 to ~10 (however many fit on my display). If I "quickly" double click cell [row 500, column 3], then the screen only "left scrolls" a small amount, which sort of solves the problem. However, this seems like a foolish solution.

There MUST be some way to select a single cell in a scroll locked column (with multiple surrounding scroll locked columns) without selecting all columns in between and experiencing this "left scroll" phenomenon. Perhaps some sort of Alt/Ctrl/Shift combination? Or, some buried JMP setting? In any case, the JMP website has not proven helpful: Working with Data Tables

Thank you, Andrew

0 Kudos
1 ACCEPTED SOLUTION

Accepted Solutions
sadhammer
Community Trekker

Re: How to select single cell when multiple columns are scroll locked?

Dear. Michael,

Thank you for the reply. Not sure if I have institutional access to upgrade. In any case, right-click > copy "solves" the problem.

Regards, Andrew

0 Kudos
2 REPLIES 2
michaelhaslam_p
Community Trekker

Re: How to select single cell when multiple columns are scroll locked?

Sadhammer,

I do not see this behavior in JMP 9.0.3 nor in 10.0.2.  I do not have a JMP 9.0.1 install to test.  Can you upgrade?

Michael

0 Kudos
sadhammer
Community Trekker

Re: How to select single cell when multiple columns are scroll locked?

Dear. Michael,

Thank you for the reply. Not sure if I have institutional access to upgrade. In any case, right-click > copy "solves" the problem.

Regards, Andrew

0 Kudos