Subscribe Bookmark RSS Feed

How to "yyyy-mm-dd hh:mm:ss" format (and not w/ the "T")

djhanson

Community Trekker

Joined:

Jun 23, 2011

Does anyone know if JSL can format time in columns as "yyyy-mm-dd hh:mm:ss", that is a space between the dd and hh and not the capital "T" that JMP wants to insert?  I have tried this, but it ends up converting to serial, exactly not what I want of course.  Likewise, I do not like that capital "T" stuff that JMP does period.  The format I've mentioned is highly used in industry and I'm hoping JSL/JMP can someway support it.

Reason being: SQL uses this format, that is a space between dd and hh and has no idea what to do with a capital "T" of course.  So when saving a .csv with time data via JSL, this gets all messed up.  thanks... dj

4 REPLIES

I'm not a JMP guy so can't give you the answer. Are you aware though that the datetime format with a "T" you don't like is an ISO standard?

ms

Super User

Joined:

Jun 23, 2011

Try set format to "Local Date Time h.m.s". In my setting that results in e.g. 1995-12-12 10.00.00 (this is also preserved in CSV export). I can easily change my system to use 1995-12-12 10:00:00 or any other format which JMP then uses (relaunch required, at least on my Mac).

djhanson

Community Trekker

Joined:

Jun 23, 2011

Thanks Patrick - I did not realize it was an ISO standard.  I wish SQL would use it:).

MS, thanks for that idea.

I tried the following, as JSL hover over states slightly different, but both gave me slashes ("/") and not dashes ("-").

:MyTime<<Format("Local Date Time h.m.s");

:MyTime<<Format("Locale Date Time h:m:s");

I'm using JMP 9.0.3, else wonder if there is some global preference maybe I need to set to get this format ("yyyy-mm-dd hh:mm:ss")?  dj

ms

Super User

Joined:

Jun 23, 2011

JMP's local date time format is supposed to use the settings of your OS. What I meant was that you can globally change the date/time format on your computer to match the format you desire. Unfortunately that may interfere with other software but it's easy to revert. I think the use of slashes is US tradition. Try to pick another country in the date time settings (on the mac it's a drop-down menu and detailed customization options in a system control panel. I don't have access to Windows right now but it should be there somewhere...).