Share your ideas for the JMP Scripting Unsession at Discovery Summit by September 17th. We hope to see you there!
Choose Language Hide Translation Bar
Highlighted
Assaf1
Level III

How to disable JMP security warning

Hi,

When I open files with scripts, I got "JMP security warning" with three options: Examine, Open and cancel (see attached).

The option for "always ask before opening this file" is disable.

How can I disable it and make the JMP to always open it w/o this popup?

Thanks in advance!

Assa

JMP security warning.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Craige_Hales
Staff (Retired)

Re: How to disable JMP security warning

The file server share needs to be added to your trusted zone.

Server is not in the trusted zone, yetServer is not in the trusted zone, yet

to implicitly trust content from this share, use the control panel Internet Options applet. (Note that anyone that has access to the server can change the file. That's why it isn't implicitly trusted by default.)

Control Panel internet optionsControl Panel internet options go to the security tab.

Choose the security tabChoose the security tab

open the local intranet sites.

Pick local intranetPick local intranet

go to the advanced settings.

Advanced settingsAdvanced settings

I needed two different names for the same place. VBoxSvr is the name of the server, and H:\ is a drive letter mapping.

Look at the server shares in the explorerLook at the server shares in the explorer

Add a drive letterAdd a drive letter

add them both, then close/OK all the way back.

Add the serverAdd the server

No more security prompt!

The three check boxes on the sites dialog also make it work, but I think it is better to be a little more specific with the advanced dialog about which servers are OK.

Craige

View solution in original post

8 REPLIES 8
Highlighted
Craige_Hales
Staff (Retired)

Re: How to disable JMP security warning

The file server share needs to be added to your trusted zone.

Server is not in the trusted zone, yetServer is not in the trusted zone, yet

to implicitly trust content from this share, use the control panel Internet Options applet. (Note that anyone that has access to the server can change the file. That's why it isn't implicitly trusted by default.)

Control Panel internet optionsControl Panel internet options go to the security tab.

Choose the security tabChoose the security tab

open the local intranet sites.

Pick local intranetPick local intranet

go to the advanced settings.

Advanced settingsAdvanced settings

I needed two different names for the same place. VBoxSvr is the name of the server, and H:\ is a drive letter mapping.

Look at the server shares in the explorerLook at the server shares in the explorer

Add a drive letterAdd a drive letter

add them both, then close/OK all the way back.

Add the serverAdd the server

No more security prompt!

The three check boxes on the sites dialog also make it work, but I think it is better to be a little more specific with the advanced dialog about which servers are OK.

Craige

View solution in original post

Highlighted
Assaf1
Level III

Re: How to disable JMP security warning

Fixed!!!

Thanks for your detailed support.

Appritiate

Assaf

Highlighted
Flojgaard
Level II

Re: How to disable JMP security warning

Hi.

 

Do you know if it is possible to disable the security warning from the JMP-end, perhaps from the preferences?

 

The reason being that the Internet Options settings in many organisations are configured by the administrator. Thereby making the solution slightly more complicated.

 

From the same computer with both JMP 13 and JMP 14 installed, it is only an issue with the security warning in JMP 14. I would therefore think that the issue should be configurable in JMP. This is supported by the "Always ask before opening this file" check-box, which unfortunately is greyed out.

 

I look forward to hear from you.

 

Br, Christian

Christian Flojgaard
MSc Eng.
E-mail: christian_flojgaard@hotmail.com
Highlighted
Craige_Hales
Staff (Retired)

Re: How to disable JMP security warning

There is no JMP preference to ignore the Windows internet zone security settings. You can control the prompting behavior from JSL scripts. See https://www.jmp.com/support/help/14/table-scripts.shtml#1448859 which describes the Quarantine Action parameter in the Open function. 

You can also move the file to a trusted zone that is shared between users, or local to your machine.

Craige
Highlighted
Flojgaard
Level II

Re: How to disable JMP security warning

Thanks for your suggestion. And the Quarantine Action function works for me.

It would however be great if this could be configured in JMP because that would avoid the issues of:

  • It is not always poosible to move files, nor configure a shared drive as trusted
  • Scripts that have previously worked in JMP 13 will need to be revised if the Quarantine Action function has to be implemented throughout the code.

It seems to me like it is an issue with JMP, as version 13 did not have this "feature" :)

Christian Flojgaard
MSc Eng.
E-mail: christian_flojgaard@hotmail.com
Highlighted
msharp
Super User

Re: How to disable JMP security warning

Security features are often an inconvience but are added on purpose as a feature.  I personally see this as an improvement.  There's also no reason for JMP 14 to be backwards compatible for every feature.  Yes, everytime you update you need to revise your scripts, but this is true in every language.

Highlighted
Phil_Brown
Super User

Re: How to disable JMP security warning

Hi Craige,

Thanks for the explanation. However, what if you're in a IT restricted situation? Where you have no control or access to the Internet Options?

 

image.png

PDB
Highlighted
KSS
KSS
Level I

Re: How to disable JMP security warning

Craige, thank you for this solution. I am having trouble applying it to Google Drive File Stream. It's not a shared or mounted drive, but rather shows up as a drive letter. I've tried several combinations but JMP persists on the warning. Any advice?

Article Labels

    There are no labels assigned to this post.