Subscribe Bookmark RSS Feed

Error deleting row in table when sync'ed to Distribution platform

mikedriscoll

Community Trekker

Joined:

Jun 23, 2011

Hi,

I've noticed that JMP throws errors when deleting rows in a data table, where the table in sync'ed to a Distribution platform.  I haven't exhaustively checked other platforms, but it does not throw an error for Oneway or Variability Gauge.

Does anyone know how to suppress this error?  If I have a report with several hundred or thousand parameters, I have to hit enter (or click ok) several hundred or thousand times... may as well just manually close JMP through task manager and re-start.

Here's a screen shot of the error, which gets thrown (N+1)*G times, where N is the number of parameters plotted in the distribution platform, and G is the number of groups in a grouping parameter.

3860_pastedImage_3.png

To duplicate the problem, run a histogram and delete any row or multiple rows. Or run this script and delete a row. The error comes up 3 times for me, not sure if it is something to do w/ my Distribution platform preferences.

clear globals();

names default to here(1);

dt=open("$SAMPLE_DATA/Solubility.jmp");

Distribution(

      Stack( 1 ),

      Continuous Distribution(

            Column( :Name( "1-Octanol" ) ),

            Horizontal Layout( 1 ),

            Vertical( 0 ),

            Outlier Box Plot Row Cutoff( 1000000 ),

            Customize Summary Statistics(

                  Std Err Mean( 0 ),

                  Upper Mean Confidence Interval( 0 ),

                  Lower Mean Confidence Interval( 0 ),

                  N Missing( 1 ),

                  Range( 1 )

            )

      ),

     

      Continuous Distribution(

            Column( :Hexane ),

            Horizontal Layout( 1 ),

            Vertical( 0 ),

            Outlier Box Plot Row Cutoff( 1000000 ),

            Customize Summary Statistics(

                  Std Err Mean( 0 ),

                  Upper Mean Confidence Interval( 0 ),

                  Lower Mean Confidence Interval( 0 ),

                  N Missing( 1 ),

                  Range( 1 )

            )

      )

);

//dt << delete rows(1);  // does not throw alarm if contained within script... only if deleting manually after histogram is run.




Thanks,

Mike

1 ACCEPTED SOLUTION

Accepted Solutions
Solution

If you go to your distribution(s) red triangle>script>Auto Recalc this message should be suppressed.

3 REPLIES
Solution

If you go to your distribution(s) red triangle>script>Auto Recalc this message should be suppressed.

mikedriscoll

Community Trekker

Joined:

Jun 23, 2011

Thanks, that works.  It would be nice if JMP had a distribution preference that allowed this to be enabled by default.

For my script, i've added ",automatic recalc(1)" to the last part of the distribution() command in my script and now it suppresses that error for reports generated by my script.

Edit:  However, it does need to re-draw all of the histograms which took a few minutes for about 400 parameters.  I'll reword what I said above... It would be nice if JMP gave a preference option and a scripting command to either recalculate everything by default or not recalc but suppress errors.  Or at the very least, show one error per report. 

-Mike

louv

Staff

Joined:

Jun 23, 2011

No problem. Please submit your request to support@jmp.com so it can be noted as a customer request.