Subscribe Bookmark RSS Feed

Change format in script

stvwllc76

Community Trekker

Joined:

Nov 19, 2012

So, I have generated a data table and I have changed the format of data in a table to reflect only 1 sig digit, save the script to the data table and then ran the script.  The format reverts back to the "best" format for this column.  Is there an easy way to set this so that it maintains my format changes?

3 REPLIES
XanGregg

Staff

Joined:

Jun 23, 2011

Can you be more specific? I'm guessing the "data table" you generated was a table in some analysis report, in which case knowing the analysis type may help understand the problem.

stvwllc76

Community Trekker

Joined:

Nov 19, 2012

Sure.  I am making a VERY simple table that describes mean values.  I only want to show the mean to the first decimal place, but JMP table will show me out to 8 decimals.  I go to the "Change Format" tab  and change the format from 10, Best to 10, 1.  I then save the script to the data table.  When I run the script the format has been set back to 10, Best and I have 8 decimal places again.  This is very annoying and wonder if there is a setting that I am missing.

Does this help?

Byron_JMP

Staff

Joined:

Apr 26, 2012

In Tabulate, when you use the change format option, the steps you described above change the column width to 1.

If you check the box "use same decimal format", then you will see an option for "Fixed Dec", pick 1, leave the field width alone, click Set Format and then OK.

When you save this tabulate script to your data table it will come back the same way you left it.