Subscribe Bookmark RSS Feed

Assignment of filetypes to unknown file endinds for JMP

Dear JMP experts,

my concern is quite simple. Opening a file with a jmp-unknown ending, lets say a file "file.unknown_ending" results in jmp opening 10 instances and terminating with the error message ( in the 11th instance)

"This license of JMP allows a maximum of 10 instances to run at the same time.
This is instance number: 11.
You may wish to consider purchasing an annual license for JMP.
Please contact your JMP account representative."

, leaving the 10 empty instances open.

Opening the file via "File->Open" allows me to open the file. I have to tell jmp the file type (always a txt-file). Then jmp is able to open the file accordingly.

My question is:

How can I tell jmp, that each time I want to open the file with "unknown_ending" as ending, it has to treat this file as a txt file (compare file->open)?

Thanks in advance for your patience with my little beginners question.

Best,
Raffael.
3 REPLIES
pmroz

Super User

Joined:

Jun 23, 2011

Hello Raffael,

Open the file using File > Open. Select All Files (*.*) and select your file (file.unknown_ending). JMP will ask what type of file this is - select .txt (if this is the right type).

Once the file has been read in correctly, click on the little red triangle marked "Source", and select Edit. Use that JSL code to open future files of type ".unknown_ending" and you're all set.

I tried this by:

- Saving Big Class as a tab-delimited .txt file
- Renamed it to "Big Class.unknown_ending"
- File > Open, All files (*.*), selected the file
- Told JMP it is a .txt file

Here's the JSL code from the red triangle:

Hello,

thanks a lot PMroz for your help. Thats very kind of you.

Opening the file via "File"-> "Open" and then telling JMP of what type the file is, still works fine. The JSL Source is also set, as described by you.

As I open the file from WinXP, right click "open with ..." using JMP, each time, as described above, the 11 instances open up, but I cannot see the file`s content. The file can only be opened by "File" -> "Open". Unfortunatelly thats really circuitous. I thought there would be a possibilty telling JMP to give him the list of file_ending, which have to be opened in a certain way.

For example to set in the preferences to treat all files, ending with ".xyz", .abcd", ".bak" as txt files. Is that possible?

As an example I can say, that a file whose name is "one.map" for example is opened by the SAS XML Mapper Program. My goal is simply to tell JMP to open also such a file and handle it while opening as a txt file (automatically, when opened out of the explorer by rightclick->open) and not always via the indirection of "File"->"Open")

I really hope that I didnt misunderstand you PMroz, if you already offered me the correct solution. If that was the point, could you please refine your statement a little bit? Please correct me, if I cant see the point here.

Thanks again,
Raffael
ms

Super User

Joined:

Jun 23, 2011

Seem partly be a Windows issue. Maybe you can get around that behavior by using a startup script that check if the file is of that particular type and, if so, automatically run a script similar to what PMroz suggested.

For how to set an startup script (must be named jmpStart.jsl), look at p. 133 in the JMP 8 Scripting Guide (I have Mac OS X and can't test it myself, and I have never experienced multiple instances of JMP)