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Abstract 

While the value of a good visualization in summarizing research results is difficult to overstate, selection 

of the right medium for sharing with colleagues, industry peers, and the greater community is equally 

important. In this presentation, we will walk through the spectrum of formats used for disseminating 

data, results, and visualizations, and discuss the benefits and limitations of each. A brief overview of JMP 

Live features sets the stage for an exciting array of potential applications. We will demonstrate how to 

publish JMP graphics to JMP Live using the rich interactive interface and scripting methods, providing 

examples and guidance for choosing the best approach. The presentation culminates with a showcase of 

a custom JMP Live publishing interface for JMP Clinical results, including the considerations made in 

designing the dialog, the mechanics of the publishing framework, the structure of JMP Live reports and 

their relationship to the JMP Clinical client reports, and a discussion of potential consumption patterns 

for published reviews. 

 

Introduction 

Two powerful JMP products extend JMP in exciting ways. One of them, JMP Clinical, offers rich 

visualization, analytical, and data management capabilities for ensuring Clinical trial safety and efficacy. 

The other, JMP Live, houses these JMP visualizations on a secure and convenient platform that allows a 

wider group of users to interact with them from a web browser. As data analysis and visualization 

becomes an increasingly collaborative effort, it is important that both creating and sharing is easy. Both 

products shine at these tasks. 

“Collaborative Visualization” is defined by Isenberg et al., 2011, as "the shared use of computer-

supported, interactive, visual representations of data by more than one person with the common goal of 

contribution to joint information processing activities." This definition captures the essence of what 

JMP, JMP Clinical, and JMP Live can provide. 

When thinking about the various situations in which collaborative visualization occurs, it is useful to 

consult the space-time matrix (Baecker, 1993; Dix, et al., 1998; Isenberg, et al. 2011) (Figure 1). In the 

upper left, we have the traditional model of classroom learning and office meetings, with all participants 

in the same place at the same time. Next, we have participants in different locations at the same time. 

The lower-left depicts a shared space but with participants interacting with visualizations at different 

times, such as in the case of shift-workers. Finally, an increasingly common scenario is shown at the 

lower-right with flexibility in both space and time, as when participants can interact with the 

visualizations from different points on the globe, at any time of day. JMP Live can facilitate this scenario. 
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Figure 1. The space-time matrix of Collaborative Visualization (matrix adapted from Baecker, 1993; Dix, 

et al., 1998; and Isenberg, et al. 2011). 

 

A second way to slice through modes of collaborative visualization is by the necessary "level of 

engagement" for participants (Isenberg et al., 2011; Zambrano and Engelhardt, 2008). When it is only 

necessary to browse a few tables or high-level graphs where links to underlying data points are not 

available, simple viewing of the visualization can be sufficient. More complex graphics, or those that 

have preserved their connections to underlying data points and filters, greatly benefit by users who are 

able to not only view them, but to interact with and explore them. This includes changing filter 

selections, refreshing a view with a different column of interest, and exposing detailed data point hover-

text. Finally, users who create visualizations often have a need to share them with others, and by 

necessity will also have the ability to view, interact with, and explore the data. The nested overlay in 

Figure 2 summarizes the relationship between the three levels: Static reports when interaction is not 

necessary, JMP Live when creating is not needed, and JMP and JMP Clinical for authors who require all 

abilities. 



 

Figure 2. Nested overlay of formats and applications over the levels of engagement. 

 

A third way to think about formats and solutions is the interactivity spectrum. Static Reports such as 

PDFs are perhaps the simplest and most portable but generally the least interactive. Interactive HTML, 

also known as HTML5, allows for responsive graphics and hover text. JMP Live is built on an HTML5 

framework, but also offers server-side computations to rerun an analysis. While the features and 

abilities of JMP Live will continue to grow over time, JMP will always offer a much fuller and richer set of 

abilities, with interactivity one of its core goals. Last, there are industry-specific solutions such as JMP 

Clinical that are built on a framework of both JMP and SAS, that offer all of JMP's interactivity but with 

additional specialization. JMP Live fills the "sweet spot" of being simple and portable enough for those 

with only a web browser to access, while offering many of the prime interactive features that are 

available to JMP (Figure 3). 

 

Figure 3. The interactivity spectrum of formats and applications. 

 



The following demonstrations use both JMP Clinical and JMP Live. JMP Clinical is powerful visualization 

software built upon JMP and SAS, which is used to assess safety and efficacy of Clinical trials. It offers 

several role-based workflows for medical monitors and writers, Clinical operations, and data managers. 

Through review templates, predefined or custom report workflows can be conveniently reused on 

multiple studies, producing results that allow for easy exploration of trends and outliers. Multiple 

formats are offered for sharing these results, from static reports, an in-product Review Viewer, and new 

to JMP Clinical 8.0, JMP Live reports. JMP Live allows users with only a web browser to interact with and 

explore dynamic visualizations produced by JMP. It does so securely, and with the ability to set access 

restrictions on who can view both the graphics and underlying data tables. With the option to publish 

data filters and column switchers, users can update the view in a matter of seconds. Users can 

additionally organize their web reports with titles, descriptions, and thumbnails, and leave comments 

that facilitate a discussion between all interested parties. Explore the data on your desktop, publish it 

for sharing on JMP Live with just a few quick steps, share the results with others across your 

organization, and enrich the shared experience through communication and automation. In a Clinical 

research environment, review authors can create customized reports in JMP Clinical, with a subset of 

data scientists also using the JMP Clinical client to drill down into the results, running and exploring 

additional analyses. Either role may then choose to publish the review to share with colleagues (for 

example, medical monitors) for whom interacting with and exploring results on JMP Live is most 

convenient. Yet another team within the same organization (for example, medical doctors) may review 

the results on JMP Live and leave comments for original review authors to subsequently read and tailor 

future Clinical report options toward. 

 

Demonstrations 

Demonstration 1: Publishing a simple graphic from JMP to JMP Live 

The interactive approach is best for active exploration of JMP, impromptu requests, and deciding which 

layout and display options are best. 

1. Click on the File > Open menu command and navigate to a dataset. Click Open. 

2. Perform a JMP analysis using any platform. For example, click the Graph > Graph Builder menu 

command, drag variables into drop zones, and click Done. 

3. On the resulting graph, click on the File > Publish menu command. Specify to publish to JMP 

Live, check the Publish Data box, specify a JMP Live URL (if you have not stored one previously), 

add a desired title and description, decide who to share the report with, and click Publish. 

4. Dismiss the notification that the report has been published. You are automatically taken to the 

JMP Live URL where you can interact with and explore the results. 

The scripting approach is best when analyses and visualizations need to be quickly and reliably 

replicated, either once or as part of an ongoing scheduled task. 

1. On a new script window (File > New > Script menu command), assign the result of an Open() 

function to a data table reference, and click the Run Script toolbar button. Example: 

 
dt = Open( "C:\Program Files\SASHome\JMPClinical\15\LifeSciences\Sample 

Data\Nicardipine\SDTM\dm.sas7bdat" ); 



 

2. Run a script to perform an analysis using a JMP platform, assigning the result to a variable. 

Example: 

 
jmpreport = NewWindow("Example", 
    VListBox( 
        DataFilterContextBox( 
            HListBox( 
                dt << DataFilter( Conditional, Local, Add Filter( Columns(                                                                                       
:Age, :Study Site Identifier ) ) ), 
                dt << GraphBuilder( 
   Show Control Panel( 0 ), 
   Fit to Window( "On" ), 
   X Group Edge( "Bottom" ), 
   Variables( 
    Y( :Age ), 
    Group X( :Study Site Identifier ) 
   ), 
   Elements( Box Plot( Y, Legend( 1 ), Jitter( "None" ), Box 
Style( "Normal" ) ) ) 
                ) 
            ) 
        ) 
    ) 
); 

 

The result appears in Figure 4. 

 

 
Figure 4. Preparing a JMP report for publishing. 



3. In the same script window, run a script to publish the result to JMP Live.  (In the following 

example, replace your_URL, your_Username, and your_APIKey with your actual JMP Live URL, 

username, and API Key obtained from your JMP Live My Profile > Edit > Generate API Key.) 

webreport = New Web Report(); 
webreport << Add Report( 
 jmpreport, 
 Title( "Example" ) 
); 

 
url = webreport << Publish(URL(your_URL), Username(your_Username), 
ApiKey(your_APIKey)); 
 
If( !Is Empty( url ), 
 Web( url ) 
); 

 

4. Dismiss the notification that the report has been published. You are automatically taken to the 

JMP Live URL where you can interact with and explore the results (Figure 5). 

 

 
Figure 5. A JMP report published to JMP Live. 

 

Demonstration 2: Publishing a JMP Clinical report to JMP Live 

1. On the JMP Clinical Main Window, click on the Reviews tab. Click on the Start new Review 

button. 

2. On the Select Reports… window, add one or more reports. 

3. On the Review Builder window, run a report using the report Options > Run Report button 

(Figure 6). 



 

 
Figure 6. Running a JMP Clinical report. 

 

4. In the results for the report, click the Create Live Report button (Figure 7). Specify to publish to 

JMP Live, check Publish Data, and specify the URL and who to share the report with. Click OK. 

 

 



 
Figure 7. Publishing a JMP Clinical report. 

 

5. Dismiss the notification that the report has been published. You are automatically taken to the 

JMP Live URL where you can interact with and explore the results for the report (Figure 8). 

 

 
Figure 8. A JMP Clinical report published to JMP Live. 

Demonstration 3: Publishing a JMP Clinical review to JMP Live 

1. On the JMP Clinical Main Window, click on the Reviews tab. Click on the Start new Review 

button. 

2. On the Select Reports… window, add two or more reports. 

3. On the Review Builder window, run all reports using the Run All Reports button located on the 

review-level toolbar. 

4. On the review-level toolbar, click the Create Live Report button. Specify to publish to JMP Live, 

check Publish Data, and specify the URL and who to share the report with. Click OK. 

5. Dismiss the notification that the report has been published. You are automatically taken to the 

JMP Live URL where you can interact with and explore the results for the review. 



 

Conclusion 

JMP and JMP Clinical visualizations can be easily published and shared in a secure, controlled 

environment, while maintaining much of the original interactivity, using JMP Live. Both interactive and 

scripting methods are available for publishing JMP reports to JMP Live. In the case of JMP Clinical, an 

interactive Publish dialog is constructed with a layout similar to the interactive JMP Publish dialog for 

essential options, to allow greater familiarity for users who directly use both products. Behind the 

scenes, the code to publish a complex Clinical report or review is a JSL script that uses these essential 

options from the interactive dialog to systematically analyze a list of report graphical object references, 

and pair them with the appropriate report sections, data filters, and column switchers, in a web report 

object (Figure 9). The JSL Publish() command takes care of a lot of the work in producing a JMP Live 

report with the necessary data tables and desired visibility. Power users who have both products can 

use the download features on JMP Live to make more advanced adjustments to the initially published 

content, using their JMP client, even if they were not the original author. As you can see, JMP Live 

captures a great deal of JMP's interactivity, yet is simple enough to share with those who are not 

familiar with JMP, or for whom a web interface is more convenient. It truly makes collaborative 

visualization possible. 

 

Figure 9. Publishing from JMP Clinical to JMP Live using a combination of interactive and scripting 

approaches. (Reproduced and adapted from https://www.jmp.com/en_us/software/collaborative-

analytics-software.html.) 

https://www.jmp.com/en_us/software/collaborative-analytics-software.html
https://www.jmp.com/en_us/software/collaborative-analytics-software.html
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