
 

Sharing JMP Graphs and 
Reports 

 

 

 

Bryan Fricke 

Michael Hecht 

John Powell 

Heman Robinson 

 
 
 
 

 
 

SAS Campus Drive 
Building T 

Cary, NC 27513 
1.919.677.8000 



 

Table of Contents 
Table of Contents 2 

Contact Information 4 

Abstract 4 

Introduction 4 

Conventions 4 

Export Publication-Quality Graphics 6 

Raster Images 6 

Vector Graphics 9 

When Would You Choose One Image Type vs. the Other? 9 

Supported Image File Formats 10 

Export a JMP Report as an Image 11 

Export Images on Macintosh 11 

Export Images on Windows 11 

Setting Dots per Inch (DPI) 12 

PDF Options on Windows 13 

Export Images via JSL 13 

Transparency in Images 14 

Export GIF Animations (Windows Only) 16 

Select and Export Part of a Report 17 

Select Part of a Report 17 

Export Part of a Report 18 

Alternative 1: Saving a Selection 18 

Alternative 2: Pasting a selection to another program 18 

Copy a Report to Another Application 18 

Save a Report Image Using Apple Preview 19 

Paste a Report into Microsoft Word for Windows 19 

Flowcharts for Exporting Report Images 21 

Export for Word Processing & Print Publishing 23 

Export for Word Processing 23 

Text Format (TXT) 23 



 

Rich Text Format (RTF) 24 

Microsoft Word 2000+ Format (DOC) (Windows Only) 25 

Export for Print Publishing 26 

Export to Print Ready PDF on Macintosh 26 

Export to Print Ready PDF on Windows 28 

Preview PDF in Windows Prior to Export 28 

Export to Print Ready PDF via JSL 29 

Export for Presentation 30 

Export to PowerPoint on Macintosh 30 

Export to PowerPoint on Windows 31 

Export to PowerPoint via JSL 31 

Export to a Web Browser 32 

Export Static HTML 32 

Export Static HTML on Macintosh 33 

Export Static HTML on Windows 33 

Export Static HTML via JSL 33 

Export Interactive HTML 34 

Export Interactive HTML on Macintosh 35 

Export Interactive HTML on Windows 35 

Export Interactive HTML via JSL 36 

Supported Browsers 36 

Unsupported Features 36 

Sharing Your Data 38 

How to Share 38 

Dashboard Support 39 

Publishing a Web Report 40 

Export a Web Report 41 

Export a Web Report via JSL 44 

Conclusion 45 

References 45 

  



 

Contact Information 
Bryan Fricke, JMP Senior Software Developer, SAS, Bryan.Fricke@jmp.com 
Michael Hecht, JMP Principal Systems Developer, SAS, Michael.Hecht@jmp.com 

Abstract 
Sharing JMP Graphs and Reports 
 
JMP is the tool of choice for visually exploring and making discoveries about your data. 
However, since not everyone is a JMP user, you may need to export your graphs and reports in 
a form tailored to your audience. In this session, we will demonstrate how to get graphs and 
reports out of JMP and into forms suitable for sharing. In particular, we will cover exporting 
graphs and reports in forms ready for printed journals or articles, presentations, and interactive 
web pages.  

Introduction 
How you share reports and graphs depends on the needs of your users. No one way of sharing 
is suited for every need. In this paper, we show you how to export reports and graphs for use in 
the following activities: 
 

● Image Processing 
● Word Processing & Publication 
● Presentation 
● Web Browsing 

 
The ways in which you can produce graphs and reports for these varied mediums are both rich 
and nuanced. This paper provides detailed guidance for getting the results you need. 

Conventions 
For simplicity, we refer to both reports and graphs as reports in this paper. We only make a 
distinction between reports and graphs when referring to a graph contained within a report. 
 
When providing instructions for how to export your reports on Windows, we leave out 
instructions for how to reveal a report’s menu bar. By default, JMP automatically hides the 
report menu bar. To reveal the menu bar, perform the following procedure: 
 

mailto:bryan.fricke@jmp.com
mailto:Michael.Hecht@jmp.com


 

1. Click the blue bar near the top of the report window as shown by the red arrow in 
Figure 1 below.  

 
Figure 1. Hidden menu bar 
 

2. After clicking the blue bar, the report menu bar is revealed as shown in Figure 2. 

 
Figure 2. Revealed menubar 
 

The instructions in this paper assume the menu bar is already revealed whenever it indicates 
that one of the menu bar options should be selected. 
 
The paper provides JMP Scripting Language (JSL) commands and examples. You can type in or 
copy the examples into a scripting window. To open a script window, select File > New > New 
Script in the app menu bar on Macintosh or File > New > Script in the report window menu bar 
on Windows. After adding the text of a script to the window, click the Run Script button near 
the top of the scripting window to run your script. 



 

Export Publication-Quality Graphics 
Sometimes you may want to export an image of all or part of your report for inclusion in a 
presentation, a document, or to share with others. Exporting an image is very much like taking 
a  picture with a digital camera or a mobile device. While people sometimes “edit” pictures, 
they typically don’t modify the individual objects that appear in the picture such as text on a 
street sign as shown in the Figure 3 below. 
 

 

Figure 3. Digital picture with text on street signs 

 
There are two major types of images that JMP exports: raster and vector. Below we discuss the 
following: 

● What are the characteristics of raster and vector images? 
● Why might you choose one vs. the other? 
● How do you export each type of image from JMP? 
● What are the different file formats into which each type of image can be stored? 

Raster Images 
A picture taken with a digital camera is made up a fixed number of colored squares or pixels. 
Such a picture is commonly known as a raster image. So, for example, the image in Figure 4 
below is 400 pixels wide and 318 pixels high for a total of 127,200 pixels.  



 

 

Figure 4. Raster image made up of 127,200 pixels 

 
The number of pixels that make up an image is commonly known as the resolution of the 
image. Typically, the resolution of an image is reported as the number of pixels wide multiplied 
by the number of pixels high (i.e., width x height). So, the resolution of the image in the above 
figure is 400 x 318. As seen in Figure 5, if you zoom into an image, you can see the individual 
pixels that make up a raster image. 
 

 

Figure 5. Zooming into a raster image reveals the constituent pixels 

 



 

It is important to know the maximum required resolution at the time of export. Scaling an 
image to a lower resolution can usually be done without losing too much detail; however, 
depending upon the scaling algorithm you may see some aliasing (i.e., small variations in the 
original image appearing as larger variations in the lower resolution image). Aliasing commonly 
appears as jagged lines or abrupt and unexpected changes in color value. The image in Figure 6 
was scaled to a lower resolution without any pixel averaging, which resulted in jagged lines and 
unexpected color changes in the text.  

 

Figure 6. Shrinking a raster image can result in visual artifacts 

 
Scaling to a higher resolution generally results in either a somewhat blurred image or an image 
where you can at least begin to see the individual pixels that make up the original image. Figure 
7 shows a picture that was scaled to a higher resolution without interpolation resulting in an 
image where you can see the individual pixels that make up the image. 

 

Figure 7. Zooming into an image reveals its pixel structure 



 

Vector Graphics 
If you want to share your reports so the final resolution can be chosen by your intended 
audience without any visual artifacts, you probably want to share your report using vector 
graphics. As shown in Figure 8, you do not see individual pixels when you zoom into a vector 
graphic. 
 

 

 

Figure 8. Vector images do not reveal artifacts when magnifying image 

 
Vector graphics store the report in terms of objects such as text, lines, curves, and polygons. 
With vector graphics, you can create raster images with an arbitrary amount of resolution at a 
later point. In addition, if you embed vector graphics inside document publishing software, the 
most appropriate print resolution for the chosen publishing medium may be selected for you. 

When Would You Choose One Image Type vs. the Other? 
If you don’t know the final required resolution at the time of export, we recommend exporting 
your reports as vector images. If, however, you know the final resolution needed by your 
audience, you may choose to export your report as a raster image. For example, you may be 
asked to submit an image for publication using a raster format (see Supported Image File 
Formats) or using a particular resolution. Even so, provided you have image processing 



 

software such as Apple Preview or Adobe Photoshop on your computer, you can use the vector 
image as the original master image and make raster copies of your image on demand. 
 

 Some graphs within a report are exported as a raster image within a vector file due to the 
way they are rendered. For example, Scatterplot 3D is exported as a raster image. 

Supported Image File Formats 
JMP supports the following vector file formats: 
 

● Portable Document Format (PDF) 
○ Current de facto standard for portable document publishing. Can be used to save 

vector graphics or a document ready for printing. 
● Scalable Vector Graphic (SVG) 

○ Standard format for publishing vector images to the Web since many web 
browsers support it natively. 

● Encapsulated PostScript File (EPS) 
○ Legacy standard for printing vector images. 

● Enhanced Metafile (EMF) (Windows only) 
○ Standard vector format used in Microsoft Office for Windows. Preserves 

transparency as described in Transparency in Images.  
 
By default, JMP supports the following raster file formats. Depending upon the manner in 
which you export a report, all these formats may not be available. 
 

● Portable Network Graphics (PNG) 
○ Suitable for web and print publishing. Preserves transparency as described in 

Transparency in Images and provides lossless compression. 
● Tagged Image File Format (TIFF) 

○ No compression is used, so it is a good format for a master raster image. 
Preserves transparency as described in Transparency in Images. It is not well 
suited for web publishing. 

● Joint Photographics Expert Group (JPEG) 
○ Most widely supported raster image format. Provides lossy compression and 

generally results in a file much smaller than a PNG. The JPEG format is good for 
reducing the file size of real world images; however, artifacts from compression 
can often be seen in the types of graphs produced by JMP. 

● CompuServe Graphics Interchange Format (GIF) 
○ Good for small images like logos, and brief animations. GIF images are suitable 

for web publishing. Preserves transparency as described in Transparency in 
Images and provides lossless compression using an index of colors. Typically, the 
index is limited to 256 colors. 



 

Export a JMP Report as an Image 
In this section, we explain how to export reports as images on both Macintosh and Windows 
computers. 

Export Images on Macintosh 

To export to any of the supported vector or raster file types, perform the following procedure: 
1. On the app menu bar, select File > Export > Image. 
2. On the export dialog, select the radio button next to Image. 
3. From the Format drop down box next to the Image option, select any of the following 

image file formats: PNG, TIFF, PDF, SVG, or EPS as shown in Figure 9.  
 

 

Figure 9. Macintosh Export > Image format options 

 

 If you wish to save to JPEG or GIF, follow the procedure given in Export Images via 
JSL, Selecting Only Part of a Report for Export or Copying a Report to Another 
Application. 

4. Click the Next…… button at the bottom of the export dialog. 
5. From the save file dialog that appears, give the image a suitable name and an 

appropriate location on a storage device. 
a. Optionally, choose to view the file immediately upon export by clicking the 

checkbox next to the label which reads, “Open the file after saving”. 
6. Click the Export button. 

 
If you enabled the option to view the file at export, the file is first saved to a storage device and 
the application registered to handle the exported file type opens and displays the file. 

Export Images on Windows 
To save your report as an image on Windows, perform the following procedure: 
 

1. Select File > Save As…… on the report menu bar. 
a. If you wish to export only part of the report, see Select Part of a Report and then 

Alternative 1: Saving a Selection. 
2. Choose any of the previously mentioned file formats.  
3. Choose a suitable name for the file. 



 

4. Optionally, change the DPI in the drop down if you are saving to a raster format other 
than GIF. See Setting Dots per Inch (DPI) below for more information. 

5. Click the Save button. When a vector file format other than PDF is chosen, the report is 
immediately exported. If an application is registered to support the file format, it 
launches to show the exported report. If saving to PDF, see the following section 
regarding PDF Options on Windows. 

Setting Dots per Inch (DPI) 
DPI with respect to raster image files is equivalent to pixels per inch (PPI). For computer 
displays, DPI is a logical rather than physical measure. For example, JMP on a Macintosh 
computer assumes the display is 72 DPI whereas JMP on a Windows computer assumes 96 DPI. 
In reality, 72 pixels on a Macintosh display device or 96 pixels on a Windows display device may 
be smaller (typical) or larger than an inch.  
 

 On a Macintosh computer, you cannot change the default DPI of 72 when exporting raster 
images from JMP. This means you can only export reports at the same resolution as they are 
displayed on your screen.  

Nonetheless, you can still save a report or any part of a report to any desired resolution 
using the method described in the section below entitled Copy a Report to Another Application. 
 
In step 4 of Export Images on Windows, if you are saving to a raster file format other the GIF on 
a Windows computer, you can choose to save to one of the following DPI values: default (i.e., 
96), 300, 600, and 1,200 as shown in Figure 10.  
 

 

 

Figure 10. Windows DPI options 

 
 

Since the default DPI exports the report at the same resolution as is displayed on your screen 
(assumed to be 96 DPI) you can divide the DPI you choose by 96 to determine how much your 
image is scaled at each of the values. For example, if you export at 300 DPI, you are effectively 
scaling the report as seen on your screen by a factor of 3.125 (i.e., 300 DPI divided by 96 DPI). In 
particular, if your report is displayed at 400 pixels wide on your screen and you export to a 
raster format at 300 DPI, the exported report will be 1,250 pixels wide (i.e., 400 pixels 
multiplied by 3.125). 



 

PDF Options on Windows 

 JMP on Windows assumes you want a paginated print ready document when selecting the 
PDF format.  

That being the case, we suggest you choose one of the other vector formats on Windows 
when you only want to save a vector image of a report or follow the procedure described in 
Export Images via JSL. If you want a print ready, paginated document with optional headers and 
footers, see Export to Print Ready PDF on Windows. If, on the other hand, you want only a 
vector image of your document in the PDF format exported directly from the JMP user 
interface, you can attempt to make some adjustments to the default parameters provided by 
JMP.  
 
Since JMP assumes you want a paginated document with headers, and possibly footers, a Page 
Setup dialog appears after clicking Save. Remove the default header information in the dialog. 
Also, ensure the report appears on a single page by adjusting the Page Scale, Paper Size, and/or 
Orientation. 
 
If you want to use the same page setup parameters for all future exports, select File > Page 
Setup and adjust the aforementioned parameters. Afterwards, click Set as Default to apply the 
settings to all future PDF exports. Even so, some reports may need additional changes to render 
to a single page and the aspect ratio of the page is unlikely to match your report image exactly. 

Export Images via JSL 
You can also export report images via JSL. The JSL command to save a report as an image is 
follows: 
 

obj << Save Picture( <pathname>, <format> ) 

 
In the above command, obj is the variable that references a JMP report. The <pathname> 
argument contains the path and name where you wish to save the report image on a storage 
device. The format argument can be any of the formats described in Supported File Formats. 
 
In addition, on Windows, you can set the DPI to any desired resolution (see Setting Dots per 
Inch (DPI)) using the following command: 
 
obj << Save Image DPI( number ) 
 
An example of how to use the Save Picture and Save Image DPI commands are shown below:  
 

Preferences[1] << Set( Save Image DPI( 300 ) ); 
Open( "$SAMPLE_DATA/Big Class.jmp" ); 

biv = bivariate( y( :weight ), x( :height ) ); 

rbiv = biv << report; 

rbiv << Save Picture( "$DESKTOP/example.png", "png" ); 



 

 

The result of running the above command is a file containing the image shown in Figure 11. 

 

Figure 11. Image resulting from running the JSL Save Picture command 

 

Transparency in Images 
You can add transparency to parts of your report when exporting to the PNG, TIFF, GIF, and 
EMF formats. There two different types of of transparency that you can enable or disable. The 
first type of transparency relates to the background of reports. You can enable or disable 
background transparency of a report in the user interface with the following procedure: 

1. Select File > Preferences. 
2. Click on Reports in the Preference Group box. 
3. Enable or disable Transparent background for report PNG images by clicking the 

checkbox next to the aforementioned label. 
4. Click the OK button. 

 
You can also enable or disable background transparency with the following JSL command: 
 
obj << Set( Transparent background for report PNG images( state=0|1 

)) 

 

 Despite the command referencing PNG images in its name, it also applies to the PNG, TIFF, 
GIF, and EMF file types. 
 



 

The obj variable references the JMP preferences object and receives a message to update the 
background transparency to either off (i.e., 0) or on (i.e., 1).  
 
The second type of command enables or disables the fill color used behind the graphs 
contained within a report. This type of transparency can only be set with the following JSL 
command. 
 
obj << Set Background Fill( state=0|1 ) 

 
The obj variable references the graphical user interface element in which a report is shown. 
This object receives the message to update the graph fill color to be unfilled (i.e., 0) or filled 
(i.e., 1).  
 
The two types of transparency interact to provide four different transparency modes as shown 
in Figure 12 below. 
 

Figure 12. Two transparency parameters yield four different transparency modes 

 

An example of how to produce the report in the lower right of the above figure is as follows: 
 



 

Names Default To Here( 1 ); 

Open( "$SAMPLE_DATA/Big Class.jmp" ); 

biv = bivariate( y( :weight ), x( :height ) ); 

rbiv = biv << report; 

 

// Caution: Changing a preference will affect the default  

// behavior of JMP.  

Preferences[1] << Set( Transparent background for report PNG images( 

1 ) ); 

 

framebox = rbiv[Frame Box( 1 )]; 

framebox << Set Background Fill( 0 ); 

rbiv << Save Picture( "$DESKTOP/exampleBackground0Fill1.png", "png" 

); 

Export GIF Animations (Windows Only) 
If you are using a Local Data Filter, Column Switcher, or Dynamic Bubble Plot, you can capture 
dynamic changes to a graph with a animated GIF. Details about each of the aforementioned 
features is beyond the scope of this paper; however, an example of how to record an animation 
is provided below. 
 

Open “Napoleons March.jmp” in the Sample Data Library. Click on the green arrow  next to 
the Bubble Plot script and you will see at the bottom of the report GIF animation control 
buttons as shown in Figure 13. 
 

 

Figure 13. GIF animation controls 

 
The three buttons to the left move the progress slider back one increment , through the 
entire sequence , and forward one increment , respectively. The record button with a red 
circle around a play icon , records any changes to the Progress sequence made to the report 

once pressed. Once recording has started, the record button changes to a stop button . To 
stop recording changes to the Progress sequence, press the stop button. To save the animation, 
press the save button , which was enabled once you started recording changes made to the 
Progress sequence. 
 
Figure 14 shows an animated GIF of Napoleon’s March. 
 



 

 
Figure 14. Napoleon’s March 

Select and Export Part of a Report  
Sometimes you may want to export only a portion of a report. The below procedure applies to 
saving a selection as an image as described in Export Publication-Quality Graphics; however, it 
also relates to Export for Word Processing & Print Publishing Software and Export for 
Presentation, which are discussed in more detail later in the paper. 

Select Part of a Report 
1. Select the selector tool on the toolbar menu above the graph you wish to save as a 

vector graphic or use the keyboard shortcut by clicking “s”. The selector tool button 
looks like a plus sign as shown in Figure 15. 

 

Figure 15. Selector control button appears as a plus sign in the toolbar 

 
2. Select either the entire report by clicking near the edge of the report or right clicking on 

the report and selecting Select All from the popup menu, or select any portion of the 
report by clicking on any part of the report (selected elements turn blue). To select 
multiple report elements, click and drag over the items you wish to select or hold the 
Shift key and click each element you wish to add to the selection.  



 

Export Part of a Report 
Once you have selected part of a report, there are two methods for exporting the selection. 

Alternative 1: Saving a Selection 
On a Windows computer, perform the following steps: 

1. Select Edit > Save Selection As…… on the report window menu bar. 
2. Follow the procedure in Export Images on Windows starting at step 2 or follow the 

procedure in Export to PowerPoint on Windows.  
 
On a Macintosh, perform the following steps: 

1. Press the control key (ctrl) and select File > Save Selection As…… on the app menu bar.  
2. From the save file dialog that appears, give the image a suitable name and an 

appropriate location on a storage device. 
3. By default, the image is saved to the PNG format. 

a. Except for TIFF and EMF, you can save to the other formats described in 
Supported Image File Formats by changing the file extension from “.png” to one 
of the other format extensions. For example, you can save to the GIF format by 
changing the extension to “.gif”. 

b. If you change the extension to “.pdf”, the resulting file is not sized to the 
content. Rather it is paginated and contains headers as explained in Export for 
Print Publishing.  

c. If you only wish to save the selected portion of the report as a PDF image 
without pagination, headers, or footers, follow the procedure detailed in Copy a 
Report to Another Application. 

4. Optionally, choose to enable or disable the option to view the file immediately upon 
export by clicking the check box next to text “Open the file after saving”. 

5. Click the Export button. 

Alternative 2: Pasting a selection to another program 
Follow the procedure outlined in the section Copying a Report to Another Application. 

Copy a Report to Another Application 
Sometimes you may want to immediately copy a report to another application. The below 
procedure assumes either you want to copy the entire report to another application or, you 
used the procedure outlined in the section Select and Export Part of a Report. 
 

1. Copy your report or selection onto the clipboard by typing CMD-C on the keyboard, 
using Edit > Copy from the app menu bar on a Macintosh  or report window if on a 



 

Windows machine, or, if you followed the procedure in Select and Export Part of a 
Report , you can right click the selection and select Copy from the pop-up menu. 

2. Open an application that supports vector or raster image formats.  
3. Paste report image from the clipboard into the application you just opened. 

 
Provided you have performed step 1 from the above outline, the below procedures give 
examples of how to paste into other applications. In particular, we describe how to paste into 
Apple Preview and Microsoft Word.  

Save a Report Image Using Apple Preview 

The below procedure outlines how to paste and save a report image to a vector or raster file in 
Apple Preview. 
 

1. Open Apple Preview. 
2. Select File > New from Clipboard from the app menu bar. 
3. Select File > Save…… from the app menu bar. 
4. Choose a suitable name and storage location for the new file. 
5. Option 1: Save to a vector file: 

a. Choose PDF from the Format drop-down list if it is not already preselected. 
6. Option 2: Save to a raster file: 

a. Choose one of the following raster formats from the Format drop-down list: 
■ JPEG 
■ JPEG-2000 
■ OpenEXR 
■ PNG 
■ TIFF 

b. Set the DPI to any desired resolution using the Resolution input box, which is 
just under the Format drop-down list as shown in Figure 16. 

 

Figure 16. DPI options on Windows 

 
Click the Save button. 
 
Depending upon your selections, you now have a vector or raster image saved to a storage 
device. 

Paste a Report into Microsoft Word for Windows 

The below procedure outlines how to paste and save a report to a vector or raster file if you are 
using a Microsoft Office application such as Microsoft Word. Note, however, that you can paste 
other formats from the clipboard in the same manner. 
 



 

1. Open Microsoft Word for Windows. 
2. Select Blank Document from the list of document types. 
3. Select the Home ribbon tab if it is not already preselected. 
4. Select the down arrow below the Paste option to reveal a drop down menu as shown in 

Figure 17 and choose the Paste Special…… option. 
 

 

Figure 17. Selecting the down arrow beneath Paste reveals a drop down menu 

 
5. From the Paste Special dialog, choose Picture (Enhanced Metafile) (see Figure 18) if you 

want to paste a vector image or Picture (PNG) if you want to paste a raster image and 
click the OK button.  

 

 

Figure 18. Options on Microsoft Windows Paste Special dialog 



 

 
6. Click the OK button.  
7. Click the File ribbon tab. 
8. Click the Save button. 
9. From the provided options, choose a suitable storage location and document type. 
10. Click the Save button. 

 
The document is now saved to disk and contains an embedded image of your report. 
 

 In the Windows example above, you can see multiple items were saved to the clipboard. 
Multiple report formats are saved to the Macintosh clipboard as well when you copy a report; 
however, most Macintosh applications do not allow you to choose which one to paste from the 
clipboard. Rather when you paste the image into the application, the application automatically 
chooses the type for you. Unfortunately, applications do not always choose the most 
appropriate format. For example, if you paste into the Apple Keynote application you may get 
RTF or a PDF depending on whether you select text and graphs in a report or only a graph.  

To ensure you get a PDF image copied into Keynote, first copy the report in JMP and then 
paste into Preview as described in Saving a Report Image Using Apple Preview. From Preview, 
copy the report again and paste into Keynote. 
 

 By default, the PNG format is used for the raster image copied to the clipboard. 

To change which image formats are copied to the clipboard, follow the below procedure. 
1. Select File > Preferences.  
2. On a Macintosh computer, click Mac OS Settings and on a Windows computer click 

Windows Specific. 
3. Select the checkboxes next to the formats you wish to have copied to the clipboard 

when copying a report. 

 On Windows, although there is a dropdown that allows you set the DPI for PNG and 
JPEG, it is not operational for 14.0. 

4. Click the OK button on the Preferences dialog. 

Flowcharts for Exporting Report Images 
The flowcharts shown in Figure 19 and 20 below direct you to previous headings in the paper 
that explain how to export an image of a report in the format you desire. In the flowcharts, we 
assume you wish to export an image of a report as opposed to any of the other export types 
discussed later in this paper. Furthermore, we assume you would prefer to use the user 
interface to export directly from JMP as opposed to copying and pasting to another application. 
 

 



 

 

Figure 19. Flowchart for saving a report on a Macintosh 

 

 

Figure 20. Flowchart for saving a report on Windows 

 



 

Export for Word Processing & Print Publishing 
Sometimes you may wish to export your report in a form that is ready for document editing 
and/or publishing. In this case, you want to export both the text and graphs in a form that is 
paginated, where each page can have headers and/or footers.  

Export for Word Processing 
To save a JMP report to a file format in which the exported text can be easily edited, perform 
the following procedure: 
 

1. Select File > Save As on Windows, or File > Export on a Macintosh. 
2. From the available file types, choose one of the following: 

a. Text Format (TXT) 
b. Rich Text Format (RTF) 
c. Microsoft Word 2000+ Format (DOC) (Windows Only) 

3. If on a Macintosh computer, click the Next…… button. 
4. Choose a suitable name and location for the file. 
5. Optionally, enable or disable the option to immediately open the file after export.  
6. In addition, you may be given additional options depending on the selected export 

format. These options are described in the sections that follow.  
7. After making your selections, click Save to create the file. 

 
Alternatively, you can copy TXT and RTF versions of reports or parts of reports in the manner 
described in Copying a Report to Another Application. 
 
Below we describe the available formats as well as any options particular to a format. In 
addition, we provide the JSL commands to export these formats. 

Text Format (TXT) 
If you only need to share unformatted text and none of the graphs in a report, then exporting 
plain text is for you. Exporting in this fashion is useful if you only want to copy some or all of the 
values presented in report tables and don’t need or want the tabular formatting. 
 
The JSL command to save to this format is as follows: 
 

obj << Save Text( <pathname> ); 

 

The pathname argument indicates the location and name of the file to be saved. An example of 
how to use the command is as follows: 
 

Open( "$SAMPLE_DATA/Big Class.jmp" ); 



 

biv = bivariate( y( :weight ), x( :height ) ); 

rbiv = biv << report; 

rbiv << Save Text( "$DESKTOP/example.txt" ); 

 
The result of running the above script is a file containing the below text: 
 

Bivariate Fit of weight By height 

Rich Text Format (RTF)  
If you want to edit a report after export in a document publishing system other Microsoft Word 
for Windows, the RTF format might be for you. Most document publishing systems will import 
from RTF, which gives you a great starting point for editing and publishing your report findings.  
When you export to RTF, text formatting and tables are maintained. You are also able to select 
the format of the images saved within the RTF file by selecting one of the following formats: 
PNG, JPEG, or EMF (Windows Only) as shown in Figure 21.  

 

 

Figure 21. Choices on Windows for image formats saved within a RTF file 

 
For more information about these file formats, please see Supported Image File Formats. 
 
If you are copying a report from JMP as described in Copying a Report to Another Application, 
you can change the image format used by RTF for the graphs in the report by following the 
below procedure: 

1. Select File > Preferences.  
2. On a Macintosh, click Mac OS Settings and on a Windows computer click Windows 

Specific. 
3. Select the desired image format type in the drop down list next to the text label Image 

format for RTF on Macintosh and Graphic format for RTF files on Windows. 
4. Click OK on the Preferences dialog. 

 
The JSL command to export to RTF is as follows: 
 

obj << Save RTF( <pathname>, <format> ); 

 
The pathname argument indicates the location and name of the file to be saved. The format 
indicates the image format used for the graphs in the report, which are embedded in the 
document. As mentioned above, the image formats can be any of the following types: 
 

● PNG 



 

● JPG/JPEG 
● EMF (Windows only) 

 
An example of how to use the command is as follows: 
 

Open( "$SAMPLE_DATA/Big Class.jmp" ); 

biv = bivariate( y( :weight ), x( :height ) ); 

rbiv = biv << report; 

rbiv << Save RTF( "$DESKTOP/example.rtf", "png" ); 

 
The result of running the above command is a document with formatted text and an image as 
shown in Figure 22. 
 

Bivariate Fit of weight By height 

 

Figure 22. Contents of an RTF generated from a JMP report 

Microsoft Word 2000+ Format (DOC) (Windows Only) 

Exporting to the Microsoft Word document format is a great choice if you are using a Windows 
computer and you know you want to edit and/or publish your document using Microsoft Word. 
Exporting to this format maintains text formatting and tables. Graphs are automatically 
converted to the EMF vector file format for maximum capability with Microsoft Word and 
optimal resolution when printing. 
 
The JSL command to save to the DOC format is as follows: 
 

obj << Save MSWord( <pathname> ); 



 

Export for Print Publishing 
Sometimes you may want to save a print ready report directly to a format that can be shared 
between computers and mobile devices of different types. Below we detail the process for 
exporting to a print ready PDF document on both Macintosh and Windows computers. 

Export to Print Ready PDF on Macintosh 
To save a JMP report to a paginated PDF with headers, follow the below procedure. If you only 
wish to create a vector image of your report, follow the procedure outlined in Export Images on 
Macintosh. 

1. Select  File > Print... on the app menu bar. 
2. Make any desired changes on the standard Macintosh print dialog (see Figure 23). Note 

you are provided with a preview of how the final document will appear. Any changes 
you make on the print dialog affects the final PDF. 

 

Figure 23. Macintosh Print dialog options 

 
3. Click the PDF drop-down list near the bottom left of the print dialog. 
4. Select Save as PDF…… from the drop-down list as shown in Figure 24. 

 



 

 

Figure 24. Macintosh print to file options  

 
5. On the PDF file save as dialog, choose a suitable storage location and filename. You may 

also provide other common PDF attributes as shown in Figure 25. 

 

Figure 25. PDF attributes dialog 

 
6. Click the Save button. 

 



 

Export to Print Ready PDF on Windows 
To save a JMP report to a paginated PDF with optional headers and/or footers, follow the 
below procedure. If on the other hand, you want only a vector or raster image of your report 
without pagination, headers, or footers, follow the procedure given in Export Images via JSL. 
 

1. Select File > Save As…… on the report menu bar. 
2. Click the drop-down list shown next to the Save as type: label. 
3. Select PDF File (*.pdf) in the list of file format types.  
4. Choose a suitable name for the file. 
5. Optionally, enable or disable the option to Open the file after saving. 
6. Click the Save button. 
7. On the Page Setup dialog (see Figure 26), modify the default document options as 

desired. 

 

Figure 26. Page Setup attributes used for PDF files on Windows 

 
8. Click OK. 

Preview PDF in Windows Prior to Export 
If you would like to see a preview of the PDF document prior to saving the file. Perform the 
following procedure: 

1. Select File > Print on the report menu bar. 
2. Select Print Preview. 
3. Select Page Setup button (see Figure 27) from the toolbar. 

 

Figure 27. Page Setup button on Windows Print Preview dialog 



 

 
4. Make any desired adjustments to the page setup options. 
5. Click the Set as Default button at the bottom left of the dialog. 
6. Click the OK button. 
7. Preview how your changes affect the document to be saved. 
8. If you are satisfied with your changes, click the “X” icon at the top right of the dialog. 

Otherwise, go back to step 3. 
9. To save the document to a PDF file, follow the procedure given in Export to Print Ready 

PDF on Windows. 

Export to Print Ready PDF via JSL 
The JSL command to export to a print ready PDF from JMP is as follows: 
 
obj << Save PDF( <pathname>, <Show Page Setup(0|1)>, Portrait(0|1)> )  

 

In the above command, obj is the variable that references a JMP report and is sent the 
command to Save PDF, which saves the report as a PDF. The <pathname> argument contains 
the path and name where you wish to save the PDF on a storage device. On Windows, Show 
Page Setup(0|1) determines whether the page setup dialog is shown prior to saving the PDF. 
On Macintosh, Show Page Setup does not have an effect. The argument Portrait(0|1) 
determines whether the PDF is saved in landscape or portrait mode. Additional commands such 
as Set Page Setup, Set Print Headers, and Set Print Footers can be used in concert with Save 
PDF to further control the formatting of the PDF file. Details about these functions are beyond 
the scope of this paper; however, you can find additional information about these functions in 
the JSL Scripting Index. To open the Scripting Index, select Help > Scripting Index.  
 
An example of how to use the Save PDF command is shown below:  
 
Names Default To Here( 1 ); 

Open( "$SAMPLE_DATA/Big Class.jmp" ); 

biv = bivariate( y( :weight ), x( :height ) ); 

rbiv = biv << report; 

rbiv << save pdf( "$DESKTOP\test.pdf" ); 

 

The result of running the above command is a one page, letter sized PDF with the content 
shown in the below figure. 



 

 

Figure 28. Result of exporting JMP report to a PDF file 

 

Export for Presentation 
Saving to PowerPoint (PPTX) is a good option if you want to create a slide deck out of a report. 
Presentation software such as Apple Keynote can also import the PowerPoint format.  
 
After saving as a PPTX file, you can rearrange the exported content and edit text. Typically, each 
heading in a report defines a separate slide. The text and graphs appearing after a report 
heading become the content of a slide. Text is saved into editable text boxes, tabular content is 
preserved as a table, and graphs are saved as images. You have the option of saving the graphs 
as raster or vector images. Raster images are captured at the same resolution as shown on the 
screen. 

Export to PowerPoint on Macintosh 
To save a JMP report to PowerPoint on a Macintosh computer, perform the following 
procedure: 

1. Select File > Export from the app menu bar. 
2. Select the radio button next to Microsoft PowerPoint. 
3. Click the Next…… button. 
4. Choose a suitable name and location for the file. 
5. Use the drop-down list next to Image Format for PowerPoint to select the desired 

export format for graphs embedded in the report. The following formats are supported: 
a. Default OS format 



 

i. The Default OS format on Macintosh is PDF. 
ii. If you intend to share the PowerPoint file with those using a Windows 

computer, choose one of the raster formats rather than the Default OS 
format since the PDF format is not supported with PowerPoint for 
Windows. 

b. PNG 
c. JPEG 

Export to PowerPoint on Windows 
To save a JMP report to PowerPoint on a Windows computer, perform the following procedure: 

1. Select File > Save As... from the report window menu bar. 
2. Choose a suitable name and location for the file. 
3. From the drop down list next to the Save as type label, select PowerPoint Presentation 

(*.pptx).  
4. Select the radio button next to the desired image type, which can be one of the 

following: PNG, JPEG, or EMF.  
5. Click the Save button. 

Export to PowerPoint via JSL 
The JSL command to export a PowerPoint file from a JMP report is as follows: 
 
obj << Save Presentation( <filename>,  

Template(<“path\to\template.pptx”>),  

<Insert( Begin|End|# ) |  

 Replace( Begin|End|# ) |  

 Append 

>,  

<Outline Titles(  

None|Hide|TopLeft|TopRight|BottomLeft|BottomRight  

)>, 

<EMF|PNG|JPG|Native>) 

 

Options are provided for the following: 
● Use an existing presentation to format the generated presentation. 
● Insert, replace or append to slides in an existing presentation. 
● Control the placement of slide outline titles. 
● Choose the raster or vector format for the graphs that appear in the presentation. 

 
An example of how to use the command is as follows: 
 

Names Default To Here( 1 ); 

Open( "$SAMPLE_DATA/Big Class.jmp" ); 

biv = bivariate( y( :weight ), x( :height ) ); 



 

rbiv = biv << report; 

rbiv << Save Presentation( "$DESKTOP/jmp_example.pptx" ); 
Open( "$DESKTOP/jmp_example.pptx" ); 

 

The result of running the above script is a slide with a title and an image as shown in Figure 29. 
 

 

Figure 29. Result of exporting a JMP report to a presentation 

 

Export to a Web Browser 

Export Static HTML 
In this section, we discuss sharing JMP reports via a web browser from JMP in a static manner. 
In the following section, Export Interactive HTML, we discuss sharing interactive content via a 
web browser.  
 
Sharing reports via HTML is a good choice when you want to guarantee maximum portability. 
Anyone with a modern computer will have a web browser on their system capable of viewing 
the exported content. The report is exported as an HTML file and a subfolder named gfx is 
created which contains separate picture files for each graph embedded in the exported report. 
You have the option of saving pictures in either a vector (SVG) or raster (PNG, JPEG, or GIF 
(Windows only)) format. We recommend PNG since it is well supported by browsers and offers 



 

lossless compression. Also, since HTML tends to be viewed on a screen, the extra resolution 
afforded by a vector image is typically not needed. If you need unlimited resolution, you can 
use the SVG vector format so your images do not become pixelated in the event that you or 
your users magnify the page using browser zoom controls. The raster formats are exported at 
the resolution displayed on your screen. 
 
Note that if a section of your report is collapsed, it is not exported to static HTML. 

Export Static HTML on Macintosh 
To save a JMP report to static HTML on a Macintosh computer, perform the following 
procedure: 

1. Select File > Export…… from the app menu bar. 
2. Select the radio button next to the HTML label. 
3. Click the Next…… button. 
4. Choose a suitable name and location for the file. 
5. Use the drop-down list next to the Graphics Format label to select the desired image 

format type for the graphs embedded within the report. The following raster and vector 
image formats are supported: 

a. PNG 
b. JPEG 
c. SVG 

Refer to Supported Image File Formats for more information about each type. 
6. Optionally, enable or disable the option to Open the file after saving. 
7. Click the Export button. 

Export Static HTML on Windows 
To save a JMP report to static HTML on a Windows computer, perform the following procedure: 

1. Select File > Save As…… on the report menu bar. 
2. Click the drop-down list shown next to the Save as type: label. 
3. Select HTML File (*.htm, *html) in the list of file format types.  
4. Choose a suitable name for the file. 
5. In the the group of radio buttons labeled Graphics File Format, choose the desired 

image format type. The following raster and vector image formats are supported: 
a. PNG 
b. JPEG 
c. SVG 
d. GIF 

Refer to Supported Image File Formats for more information about each type. 
6. Optionally, enable or disable the option to Open the file after saving. 
7. Select the Save button. 

Export Static HTML via JSL 
The JSL command to export a static HTML file from a JMP report is as follow: 
 



 

obj << Save HTML( <pathname>, <format> ) 

 
The pathname argument indicates the location and name of the file to be saved. The format 
argument indicates the image format for the graphs referenced by the created HTML page. The 
image files are save in a subfolder in the same directory in which the HTML file is saved. As 
mentioned above, the image formats can be any of the following types: 

a. PNG 
b. JPEG 
c. SVG 
d. GIF (Windows only) 

 
Open( "$SAMPLE_DATA/Big Class.jmp" ); 

biv = bivariate( y( :weight ), x( :height ) ); 

rbiv = biv << report; 

rbiv << Save HTML( "$DESKTOP/example.html" ); 
 

The result of running the above script is shown in Figure 30. 
 

 
Figure 30. Report exported to HTML 

 

Export Interactive HTML 
To this point, we have described methods for sharing JMP reports in a static way. Now we 
describe how to share JMP reports via interactive HTML Version 5, or Interactive HTML.  
 



 

Interactive HTML supports many of the exploratory features of JMP, including point 
identification, linking, brushing (Becker and Cleveland, 1987; Stuetzle, 1987) and a limited 
version of data filtering. Saved reports can be uploaded to a web server, placed in a shared 
folder, emailed to colleagues, or shared in a cloud storage service. Reports can be viewed in any 
modern web browser. 

Export Interactive HTML on Macintosh 
To save a JMP report to Interactive HTML on a Macintosh computer, perform the following 
procedure: 

1. Select File > Export... on the app menu bar.  
2. Select the ratio button next to the Interactive HTML with Data label.  
3. Click the Next…… button. 
4. Choose a suitable name and location for the Interactive HTML file. 
5. Optionally, select the check box next to Open the file after saving to enable or disable 

the option to open the file immediately upon export. 
6. Click Export. 

Export Interactive HTML on Windows 
To save a JMP report to Interactive HTML on a Windows computer, perform the following 
procedure: 

1. Select File > Save As... on on the report window. 
2. Select Interactive HTML with Data (*.htm, *.html) from the drop-down list as shown in 

Figure 31. 

 

Figure 31. Choose Interactive HTML with Data from the list of export types 

 
3. Optionally, select the check box next to Open the file after saving to enable or disable 

the option to open the file immediately upon export. 



 

4. Click Save. 
 

Export Interactive HTML via JSL 
The JSL command to export an Interactive HTML file from JMP is as follows: 
 
obj << Save Interactive HTML( <pathname> ) 

 
The report object named obj receives the message to save itself to an Interactive HTML file. The 
pathname argument provides the location and name of the file to be saved. 
 
An example of how to use the command is shown below: 
 
Names Default To Here( 1 ); 

Open( "$SAMPLE_DATA/Big Class.jmp" ); 

biv = bivariate( y( :weight ), x( :height ) ); 

rbiv = biv << report; 

rbiv << Save Interactive HTML( "$DESKTOP/example.html" ); 

Supported Browsers 
After the HTML file is saved, you can open it in any modern web browser.  JMP 14 supports 
Interactive HTML on the following devices and browsers: 
 

Device Supported Browsers 

Windows IE 11, Edge, Chrome, Firefox 

Mac Safari, Chrome, Firefox, Opera 

iPad Safari, Chrome 

Android Chrome 

Kindle Fire Silk 

Table 1. Supported Devices and Browsers 
 

Because of limited customer demand, we do not test Interactive HTML on smartphones. 
Nonetheless, it often works well on phones running Safari or Chrome browsers. Performance 
varies depending on the smartphone. 



 

Unsupported Features 

 Interactive HTML supports many of the frequently used features of JMP. If your report 
contains a feature that is not supported, you will see a warning in the dialog, and a more 
detailed message in the JMP Log. 
 
For example, on a Macintosh computer, the text (Partially Supported) is added next to the text 
description of the Interactive HTML export option. A more detailed message is displayed 
underneath the export option as shown in Figure 32. 

 

Figure 32. A message is displayed when some features are not 
supported in Interactive HTML 

 
Likewise, a Windows computer shows a message indicating the export is only partially 
supported under the export drop-down list box whenever Interactive HTML with Data (*.htm; 
*.html) is selected as shown in Figure 33. 
 

  
Figure 33. Message indicating some features are not supported in Interactive HTML 

To see the more detailed message in the log, select View > Log on either platform. Figure 34 
shows an example of the features in an exported report that are not interactive. 

 

Figure 34. Log message indicating what portions of the export are not supported 



 

 
If a graph within a report is unsupported, it is exported as a static image. Figure 35 shows that a 
three-dimensional graph is exported as a static image.  
 

 

Figure 35. Static Scatterplot 3D graph 

Sharing Your Data 
Interactive HTML enables interactivity by embedding the data table columns that are 
referenced by a report. Although the data is obfuscated, a motivated hacker will be able to gain 
access to it. So, it is best to assume you are sharing your data whenever you share an 
Interactive HTML file. 

How to Share 
All of the content appearing in an Interactive HTML page is contained within a single file. 
Although the file can be distributed like any other, it can get quite large as the referenced data 
table columns are included in the file. So, it might be worthwhile to consider alternatives to 
making copies. Although attaching an Interactive HTML file to an email may be easy, it 
consumes memory on each recipient's computer. The recipient may also be disappointed if she 



 

tries to view the attachment within email software. In some cases, the email program’s web 
page viewer is not fully functional and will be unable to properly display an Interactive HTML 
file attached to a message. 
  
One simple approach to sharing an Interactive HTML file within a company is to save the file to 
a shared network location. Afterwards, you can email a link to the desired recipients. When you 
copy the network path into an email, your email program may insert a hyperlink as well. If so, 
the recipients can simply click the link to view the file in their default browser. 
  
Another way to share Interactive HTML files is to use a cloud storage and file-sharing service 
like Dropbox, Google Drive, or Microsoft OneDrive. With these services you can save to a 
specific location on your computer and the file is automatically copied to the cloud. Once in the 
cloud, the file or directory of files can be shared with others. Each service has its own 
mechanism for sharing, but they typically create a link to the file in the cloud and send the link 
to one or more people by email. One word of caution is that these services also offer HTML file 
previews which may not be capable of displaying Interactive HTML files.  

Dashboard Support 
In JMP, you create a dashboard by combining multiple reports into a single view. You can share 
a dashboard in any of the ways already described in this paper; however, Interactive HTML is 
unique in that it is able to show interaction between the reports appearing in a dashboard. For 
example, if you make a selection in one report, the same data appearing in the other reports 
within the same dashboard are also selected as shown in the figure below.  
 

 
Figure 36. An Interactive HTML Dashboard 



 

To create a dashboard, you need to have multiple report windows open. Dashboards can be 
created using the using the Window > Combine Windows…… or File > New > Dashboard. Details 
for creating a Dashboard via the latter option are beyond the scope of this paper; however, 
when using the former option, the dialog displayed in Figure 37 is displayed. 
 

 

 

Figure 37. Example of a Combine Windows dialog 

  
Click on the reports you wish to export in the combine column. Do not use the Filter By column 
as it isn’t currently supported when exporting to Interactive HTML. Click on the Summary 
Report View option if you wish to export only the graphs contained within the reports. 

Publishing a Web Report 
A web report allows you to publish multiple JMP reports to separate Interactive HTML pages at 
the same time. When publishing a web report, an opening HTML page is created that acts as an 
index into the exported Interactive HTML pages, which is named index.html. When you direct a 
web browser to the folder in which a web report is created, it will automatically load 
index.html. For each JMP report that is exported, a reduced scale static image is captured. 
These images act as hyperlinks to their respective Interactive HTML pages. By default, these 
hyperlink images are arranged as a list within the exported index.html file. Support files, 
including the exported Interactive HTML pages, are hosted in subfolders within the same folder 
as the index.html file. An example of a web report page is shown in Figure 38. 
 
 



 

 

Figure 38. Index page of a JMP Web Report 

 
When you click on either a hyperlink image or the text appearing next to the image, the 
associated Interactive HTML page is loaded into the browser window. 
 
The web report publishing feature, was used to create all the Interactive HTML examples at 
http://www.jmp.com/jmphtml5/.  

Export a Web Report 
To create a web report, follow the below procedure: 
 

1. Select File > Publish……  
2. On the Select Reports dialog, you can perform the following operations: 

a. Select each report you would like to include in the web report. To select more 
than one report, you can press the ctrl key while clicking on each report you 

http://www.jmp.com/jmphtml5/


 

would like to export. Alternatively, you can press the shift key while selecting. All 
the reports between the first and last report you click are selected when holding 
down the shift key. Finally, you can click and drag to select all the reports you 
wish to export. 

b. Enable or disable the option to close all of the exported reports within JMP after 
the web report is created. 

c. Optionally, change the default name of the folder that is created in which 
index.html is stored. 

d. Optionally, change the default directory where the new folder will be created as 
shown in Figure 39. 

 

Figure 39. Web Report options shown on first page of creation wizard 

 
3. Select the Next button. 
4. On the Select Reports page (see Figure 40), you can optionally do the following: 

a. Change the order in which the reports appear by clicking the up and down 
arrows next to each image. 

b. Remove reports by clicking the delete button  next to each image. 
i. If you remove any reports, you will see a Restore button appear that 

allows you to add all the deleted reports back to the Select Reports page. 
c. Enable or disable the option to Open published web report immediately after 

publishing. 
d. Enable or disable the report creation timestamps by clicking the Toggle 

Timestamp button. 
e. Provide report titles and descriptions by changing the text in the edit box next to 

Title and Description, respectively. 



 

f. Provide a Web Report Title and Web Report Description in the edit boxes under 
the labels, respectively. 

g. Optionally, click the triangle next to Customizations for more options, which 
allow you to do the following: 

i. Change the Style format to one of the following:  
1. Large List: Uses a list of large images as links to the exported web 

reports. 
2. Small List: Uses a list of small images as links to the exported web 

reports. 
3. Grid: Uses a grid layout  for the images which act as links to the 

exported web reports. 
4. Custom CSS: Advanced featured for changing the look and feel of 

the index.html page that is created. 
ii. Add images to the report by clicking the Image button. Doing allows you 

to add an image where you would normally see a report. 
h. Change the font used on the web report HTML page that is created. 
i. Change the logo from the JMP logo to a user selected image. 

 

Figure 40. Second page of Web Report wizard 



 

 
5. Select the Build Report button. 

Export a Web Report via JSL 
The JSL command to export a Web Report from JMP is as follows: 
 
webreport = New Web Report( … ) 

 
The details about this function are beyond the scope of this paper; however, you can find all the 
information you need in the JMP Scripting Index. To open the Scripting Index, select Help > 
Scripting Index. Then type “New Web Report” in the search window as shown in Figure 41. 
 

 

Figure 41. JMP Scripting Index entry for the New Web Report function 

 
The below example should give you an idea of how to use this powerful JSL command. 
 
Names Default To Here( 1 ); 

Open( "$SAMPLE_DATA/Big Class.jmp", Invisible ); 

jmpreport = bivariate( y( :weight ), x( :height ) );  

webreport = New Web Report(); 
webreport << Add Report( jmpreport ); 

webreport << Index( 

Title( "Publish Test" ), 

Description( "This is a custom index page" ), 

Style( "Grid" ) 

); 

file = webreport << Save( "$DESKTOP" ); 

If( !Is Empty( file ), 

Web( file ) 

); 



 

Conclusion 
JMP offers a rich set of features for exporting your reports in a form suitable for your audience. 
No one way is right for every purpose. Once you know how your exported report will be used, 
you need to select an appropriate export method offered by JMP. The various sections in this 
paper have provided you with links between your intent and the detailed procedures needed to 
achieve your desired outcome.  
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